summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRoman Kennke <roman@kennke.org>2006-01-19 11:26:34 +0000
committerRoman Kennke <roman@kennke.org>2006-01-19 11:26:34 +0000
commitefdd297f14ec9a70ca0e9ec97716a92144954385 (patch)
tree63eb7f3dc1175e2017d146e89a4d4705cb5e3286 /configure.ac
parente03b5dd80b3f56b93964cbb064acff1feeb695d3 (diff)
downloadclasspath-efdd297f14ec9a70ca0e9ec97716a92144954385.tar.gz
2006-01-19 Roman Kennke <kennke@aicas.com>
* configure.ac: Added/fixed --enable-posix-layer option to enable build of posix layer. * native/target/Makefile.am: Added build for posix layer.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 3 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 665766e9c..3bfed6511 100644
--- a/configure.ac
+++ b/configure.ac
@@ -32,9 +32,6 @@ esac
dnl get the target for the native layer
case "$target_os" in
- linux* )
- TARGET=Linux
- ;;
* )
dnl XXX change me when transition to target native layer is done
TARGET=Linux
@@ -201,10 +198,11 @@ AC_ARG_ENABLE([posix-layer],
*) ENABLE_POSIX=yes ;;
esac],
[ENABLE_POSIX=no])
-AC_SUBST(CP_NEW)
+AC_SUBST(NEW_CP)
if test "x${ENABLE_POSIX}" = xyes; then
- AC_DEFINE(CP_NEW, 1, [defined if the posix layer should be used])
+ AC_DEFINE(NEW_CP, 1, [defined if the posix layer should be used])
fi
+AM_CONDITIONAL(CREATE_POSIX, test "x${ENABLE_POSIX}" = xyes)
dnl -----------------------------------------------------------
dnl Sets the native libraries installation dir