summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Koch <konqueror@gmx.de>2006-06-17 15:53:36 +0000
committerMichael Koch <konqueror@gmx.de>2006-06-17 15:53:36 +0000
commit7a335001905f734671772a3e2c5b94384ef68f12 (patch)
tree08aa2432307a04a012d4ff824b4e8648febf6591 /configure.ac
parent8d7bc7e0db42e944b28d99697d9f3b25a76067c9 (diff)
downloadclasspath-7a335001905f734671772a3e2c5b94384ef68f12.tar.gz
2006-0-12 Mario torre <neugens at limasoftware.net>
* gnu/java/util/prefs/GConfBasedPreferences.java: new class. * gnu/java/util/prefs/GConfBasedFactory.java: new class. * gnu/java/util/prefs/gconf/GConfNativePeer.java: new class. * gnu_java_util_prefs_gconf_GConfNativePeer.h: generated header file. * classpath/native/jni/gconf-peer/GConfNativePeer.c: new C file. + * configure.ac: update to introduce new files. Added options to build gconf native peer used by the GConf preference backend. * include/Makefile.am: update to introduce new files. * native/jni/Makefile.am update to introduce new files. * scripts/check_jni_methods.sh: added three new ignored file from check. * native/jni/gconf-peer/Makefile.am: new Makefile needed to build gconf-peer shared library.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 27 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 378e8f349..284e6f9ca 100644
--- a/configure.ac
+++ b/configure.ac
@@ -82,6 +82,25 @@ AC_ARG_ENABLE([core-jni],
[COMPILE_CORE_JNI=yes])
AM_CONDITIONAL(CREATE_CORE_JNI_LIBRARIES, test "x${COMPILE_CORE_JNI}" = xyes)
+dnl -----------------------------------------------------------
+dnl GConf native peer (enabled by default)
+dnl -----------------------------------------------------------
+AC_ARG_ENABLE([gconf-peer],
+ [AS_HELP_STRING(--disable-gconf-peer,compile GConf native peers (disabled by --disable-jni) [default=yes])],
+ [case "${enableval}" in
+ yes) COMPILE_GCONF_PEER=yes ;;
+ no) COMPILE_GCONF_PEER=no ;;
+ *) COMPILE_GCONF_PEER=yes ;;
+ esac],
+ [COMPILE_GCONF_PEER=yes])
+AM_CONDITIONAL(CREATE_GCONF_PEER_LIBRARIES, test "x${COMPILE_GCONF_PEER}" = xyes)
+
+dnl -----------------------------------------------------------
+dnl GTK native peer error checking
+dnl -----------------------------------------------------------
+AC_ARG_ENABLE([gconf-peers],,AC_MSG_ERROR([No --enable-gconf-peers (or --disable-gconf-peers) option; you want --enable-gconf-peer]))
+
+
dnl ------------------------------------------------------------
dnl Whether to compile with -Werror or not (disabled by default)
dnl ------------------------------------------------------------
@@ -432,6 +451,13 @@ if test "x${COMPILE_JNI}" = xyes; then
AC_SUBST(XTEST_LIBS)
fi
+ dnl gconf-peer
+ if test "x${COMPILE_GCONF_PEER}" = xyes; then
+ PKG_CHECK_MODULES(GCONF, gconf-2.0 >= 2.11.2)
+ AC_SUBST(GCONF_CFLAGS)
+ AC_SUBST(GCONF_LIBS)
+ fi
+
dnl Check for AWT related Qt4
if test "x${COMPILE_QT_PEER}" = xyes; then
PKG_CHECK_MODULES(QT, QtCore QtGui >= 4.1.0, HAVE_QT4="yes", HAVE_QT4="no")
@@ -719,6 +745,7 @@ native/jni/java-net/Makefile
native/jni/java-nio/Makefile
native/jni/java-util/Makefile
native/jni/gtk-peer/Makefile
+native/jni/gconf-peer/Makefile
native/jni/qt-peer/Makefile
native/jni/xmlj/Makefile
native/jni/midi-alsa/Makefile