summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMark Wielaard <mark@klomp.org>2004-02-01 16:57:24 +0000
committerMark Wielaard <mark@klomp.org>2004-02-01 16:57:24 +0000
commit75391dcfdd29b824f5ff770506e891cdb7c7d10f (patch)
tree70e7a1f2d79677d202342297f8da6ae917823154 /configure.ac
parent9dd85db02eea0e0108433d7bad043047231fbbec (diff)
downloadclasspath-75391dcfdd29b824f5ff770506e891cdb7c7d10f.tar.gz
* configure.ac: Add PKG_CHECK_MODULES check for GTHREAD.
* native/jni/gtk-peer/Makefile.am (libgtkpeer_la_LDFLAGS): Remove GLIB_LIBS, add GTHREAD_LIBS. (INCLUDES): Add GTHREAD_CFLAGS.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e18fb900c..ece1a06ca 100644
--- a/configure.ac
+++ b/configure.ac
@@ -120,8 +120,12 @@ if test "x${COMPILE_JNI}" = xyes; then
JAPHAR_GREP_CFLAGS(-Wall, [ CFLAGS="$CFLAGS -Wall" ])
fi
- dnl Check for AWT related glib/gtk/libart_lgpl
+ dnl Check for AWT related gthread/gtk/libart_lgpl
if test "x${COMPILE_GTK_PEER}" = xyes; then
+ PKG_CHECK_MODULES(GTHREAD, gthread-2.0 >= 2.2)
+ AC_SUBST(GTHREAD_CFLAGS)
+ AC_SUBST(GTHREAD_LIBS)
+
PKG_CHECK_MODULES(GTK, gtk+-2.0 >= 2.2)
AC_SUBST(GTK_CFLAGS)
AC_SUBST(GTK_LIBS)