summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMark Wielaard <mark@klomp.org>2004-12-29 21:39:35 +0000
committerMark Wielaard <mark@klomp.org>2004-12-29 21:39:35 +0000
commit4ce3a29bc0cd0364b7ceb2552a93ae99968f6229 (patch)
tree5d26bf2eb32a1b81b584209c0d3a391644880a96 /configure.ac
parent78a343044456c8f47d8d73065441cd16b4a13f98 (diff)
downloadclasspath-4ce3a29bc0cd0364b7ceb2552a93ae99968f6229.tar.gz
* configure.ac: Add --enable-xmlj option. Check for libxml2 and
libxslt libraries when enabled. Add native/jni/xmlj/Makefile. * gnu/xml/libxmlj/*: New files. * include/Makefile.am: Add XMLJ_H_FILES. Group awt gtk peer headers under GTKPEER_H_FILES. Generate new headers. * include/gnu_xml_libxmlj_*.h: New generated files. * native/jni/Makefile.am: Conditionally add xmlj dir. * native/jni/xmlj/*: New files.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 15f4f5994..08199851f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -55,6 +55,19 @@ AC_ARG_ENABLE([Werror],
[ENABLE_WERROR=no])
dnl -----------------------------------------------------------
+dnl Native libxml/xslt library (disabled by default)
+dnl -----------------------------------------------------------
+AC_ARG_ENABLE([xmlj],
+ [AS_HELP_STRING(--enable-xmlj,compile native libxml/xslt library [default=no])],
+ [case "${enableval}" in
+ yes) COMPILE_XMLJ=yes ;;
+ no) COMPILE_XMLJ=no ;;
+ *) COMPILE_XMLJ=no ;;
+ esac],
+ [COMPILE_XMLJ=no])
+AM_CONDITIONAL(CREATE_XMLJ_LIBRARY, test "x${COMPILE_XMLJ}" = xyes)
+
+dnl -----------------------------------------------------------
dnl GTK native peer (enabled by default)
dnl -----------------------------------------------------------
AC_ARG_ENABLE([gtk-peer],
@@ -198,6 +211,17 @@ if test "x${COMPILE_JNI}" = xyes; then
AC_SUBST(ERROR_CFLAGS)
fi
+ dnl Check for libxml and libxslt libraries (when xmlj is enabled).
+ if test "x${COMPILE_XMLJ}" = xyes
+ then
+ PKG_CHECK_MODULES(XML, xml2 >= 2-2.6.8)
+ PKG_CHECK_MODULES(XSLT, xslt >= 1.1.11)
+ AC_SUBST(XML_LIBS)
+ AC_SUBST(XML_CFLAGS)
+ AC_SUBST(XSLT_LIBS)
+ AC_SUBST(XSLT_CFLAGS)
+ fi
+
dnl Check for AWT related gthread/gtk/libart_lgpl
if test "x${COMPILE_GTK_PEER}" = xyes; then
PKG_CHECK_MODULES(GTK, gtk+-2.0 >= 2.4 gthread-2.0 >= 2.2 libart-2.0)
@@ -375,6 +399,7 @@ native/jni/java-net/Makefile
native/jni/java-nio/Makefile
native/jni/java-util/Makefile
native/jni/gtk-peer/Makefile
+native/jni/xmlj/Makefile
native/target/Makefile
native/target/Linux/Makefile
native/target/generic/Makefile