summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Fitzsimmons <fitzsim@redhat.com>2007-03-01 00:26:07 +0000
committerThomas Fitzsimmons <fitzsim@redhat.com>2007-03-01 00:26:07 +0000
commit7a510c3e2531682ca47fc78d068e55114abd371d (patch)
tree4547df71274328e9afc9460f1769c820b37bed6a /configure.ac
parenta8e912b79b9a5d21248fb8964f1263eb6fdaa4f4 (diff)
downloadclasspath-7a510c3e2531682ca47fc78d068e55114abd371d.tar.gz
2007-02-28 Thomas Fitzsimmons <fitzsim@redhat.com>
* INSTALL: Document --with-ecj-jar configure option and ecj jar requirement for com.sun.tools.javac support. * configure.ac: Add --with-ecj-jar configure option. * gnu/classpath/Configuration.java.in (ECJ_JAR): New field. * tools/Makefile.am: Build decendents of com and sun directories. * resource/com/sun/tools/javac/messages.properties, resource/sun/rmi/rmic/messages.properties, tools/com/sun/javadoc/ClassDoc.java, tools/com/sun/javadoc/ConstructorDoc.java, tools/com/sun/javadoc/Doc.java, tools/com/sun/javadoc/DocErrorReporter.java, tools/com/sun/javadoc/Doclet.java, tools/com/sun/javadoc/ExecutableMemberDoc.java, tools/com/sun/javadoc/FieldDoc.java, tools/com/sun/javadoc/MemberDoc.java, tools/com/sun/javadoc/MethodDoc.java, tools/com/sun/javadoc/PackageDoc.java, tools/com/sun/javadoc/ParamTag.java, tools/com/sun/javadoc/Parameter.java, tools/com/sun/javadoc/ProgramElementDoc.java, tools/com/sun/javadoc/RootDoc.java, tools/com/sun/javadoc/SeeTag.java, tools/com/sun/javadoc/SerialFieldTag.java, tools/com/sun/javadoc/SourcePosition.java, tools/com/sun/javadoc/Tag.java, tools/com/sun/javadoc/ThrowsTag.java, tools/com/sun/javadoc/Type.java, tools/com/sun/javadoc/TypeVariable.java, tools/com/sun/tools/doclets/Taglet.java, tools/com/sun/tools/javac/Main.java, tools/com/sun/tools/javac/Messages.java, tools/sun/rmi/rmic/Main.java, tools/sun/rmi/rmic/Messages.java: New files.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d9654c736..25f9522e1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -687,6 +687,19 @@ AC_SUBST(INIT_LOAD_LIBRARY)
dnl -----------------------------------------------------------
+dnl Specify the jar file containing the Eclipse Java Compiler. If
+dnl this option is not specified then the com.sun.tools.javac
+dnl implementation will not be included in tools.zip.
+dnl -----------------------------------------------------------
+AC_ARG_WITH([ecj-jar],
+ [AS_HELP_STRING([--with-ecj-jar=ABS.PATH],
+ [specify jar file containing the Eclipse Java Compiler])],
+ [ECJ_JAR=$withval]
+ )
+AC_SUBST(ECJ_JAR)
+AM_CONDITIONAL(FOUND_ECJ_JAR, test -n "$ECJ_JAR")
+
+dnl -----------------------------------------------------------
dnl Should the VM explicitly run class initialization subfunctions for
dnl java.lang.System? (default is false -- the subfunctions will be run
dnl automatically by the class initializer)