summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCasey Marshall <csm@gnu.org>2006-09-20 21:39:41 +0000
committerCasey Marshall <csm@gnu.org>2006-09-20 21:39:41 +0000
commita67151b3017805e1d027f1b170777106a5804f60 (patch)
tree54ea95163787f564dd7e74bc0bb457e15629354d /configure.ac
parent084a2d68af18443b005a1c50a20edb588d1155cb (diff)
downloadclasspath-a67151b3017805e1d027f1b170777106a5804f60.tar.gz
2006-09-20 Casey Marshall <csm@gnu.org>
* configure.ac (AC_CHECK_HEADERS): check for `sys/epoll.h.' (AC_CHECK_FUNCS): check for `epoll_create.' * gnu/java/nio/EpollSelectionKeyImpl.java: new file. * gnu/java/nio/EpollSelectorImpl.java: new file. * gnu/java/nio/SelectorProviderImpl.java (epoll_failed): new class field. (openSelector): return epoll selector if requested and available. * include/Makefile.am (H_FILES): add gnu_java_nio_EpollSelectorImpl.h. (gnu_java_nio_EpollSelectorImpl.h): new target. * include/gnu_java_nio_EpollSelectorImpl.h: new file. * native/jni/java-nio/Makefile.am (libjavanio_la_SOURCES): add gnu_java_nio_EpollSelectorImpl.c. * native/jni/java-nio/gnu_java_nio_EpollSelectorImpl.c: new file.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a918fa9ba..24c45c332 100644
--- a/configure.ac
+++ b/configure.ac
@@ -357,7 +357,7 @@ if test "x${COMPILE_JNI}" = xyes; then
fcntl.h \
sys/mman.h \
magic.h \
- sys/event.h])
+ sys/event.h sys/epoll.h])
AC_EGREP_HEADER(uint32_t, stdint.h, AC_DEFINE(HAVE_INT32_DEFINED, 1, [Define to 1 if you have uint32_t]))
AC_EGREP_HEADER(uint32_t, inttypes.h, AC_DEFINE(HAVE_INT32_DEFINED, 1, [Define to 1 if you have uint32_t]))
@@ -375,7 +375,7 @@ if test "x${COMPILE_JNI}" = xyes; then
mmap munmap mincore msync madvise getpagesize sysconf \
lstat readlink \
inet_aton inet_addr inet_pton \
- getifaddrs kqueue kevent])
+ getifaddrs kqueue kevent epoll_create])
LIBMAGIC=
AC_CHECK_LIB(magic, magic_open, LIBMAGIC=-lmagic)