summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMark Wielaard <mark@klomp.org>2006-09-24 20:12:02 +0000
committerMark Wielaard <mark@klomp.org>2006-09-24 20:12:02 +0000
commit599f5e47f99635a93a0d350b2f06086b2c34d7ee (patch)
tree3f3741b0b4ac7938a3ea0ed508f8f0d279b0635b /configure.ac
parentc7a02845a8164aad4da2c5f11d8834ed907ea424 (diff)
downloadclasspath-599f5e47f99635a93a0d350b2f06086b2c34d7ee.tar.gz
* configure.ac: Move -pedantic from WARNING to STRICT flags.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 1805eb8f8..b734635d4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -423,17 +423,17 @@ if test "x${COMPILE_JNI}" = xyes; then
dnl When using gcc we want warnings, lots of warnings :-)
if test "x${GCC}" = xyes; then
- dnl We want ISO C90 pedantic ansi, but with longlong (jlong) support
+ dnl We want ISO C90 ansi, but with longlong (jlong) support
dnl and modern POSIX and BSD C library functions/prototypes.
dnl Warning flags for (almost) everybody.
dnl Should probably be configurable
- WARNING_CFLAGS='-pedantic -W -Wall -Wmissing-declarations -Wwrite-strings -Wmissing-prototypes -Wno-long-long'
+ WARNING_CFLAGS='-W -Wall -Wmissing-declarations -Wwrite-strings -Wmissing-prototypes -Wno-long-long'
AC_SUBST(WARNING_CFLAGS)
dnl Strict warning flags which not every module uses.
dnl Should probably be configurable.
- STRICT_WARNING_CFLAGS=-Wstrict-prototypes
+ STRICT_WARNING_CFLAGS='-Wstrict-prototypes -pedantic'
AC_SUBST(STRICT_WARNING_CFLAGS)
dnl Whether or not to add -Werror, also not used by all modueles.
@@ -939,4 +939,4 @@ AC_OUTPUT
cat ${srcdir}/lib/standard.omit.in > lib/standard.omit
if test x$use_escher != xtrue; then
echo gnu/java/awt/peer/x/.*java$ >> lib/standard.omit
-fi \ No newline at end of file
+fi