summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrew John Hughes <gnu_andrew@member.fsf.org>2008-06-11 21:37:48 +0000
committerAndrew John Hughes <gnu_andrew@member.fsf.org>2008-06-11 21:37:48 +0000
commit48aa4cbbe95580832414644c0138efafbee6c9f5 (patch)
treecb6ee0b1ef899799bfb4da6e0e57d855eaa0e6c4 /configure.ac
parent3aaea725c6359443ef44b5e752a74f6b2905e377 (diff)
downloadclasspath-48aa4cbbe95580832414644c0138efafbee6c9f5.tar.gz
Forwardport native-only build fix #05.
2008-06-01 Andrew John Hughes <gnu_andrew@member.fsf.org> * configure.ac: Only run javac check if examples, tools and/or class library are being built. * scripts/check_jni_methods.sh.in: Remove duplicates in the list of JNI methods for when builddir==srcdir.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 9 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 7ec0a5138..a9cdab003 100644
--- a/configure.ac
+++ b/configure.ac
@@ -776,9 +776,6 @@ if test "x${COMPILE_JNI}" = xyes; then
AC_CONFIG_LINKS([$ac_config_links_1])
fi
-AC_PROG_JAVAC
-CLASSPATH_JAVAC_MEM_CHECK
-
CLASSPATH_WITH_CLASSLIB
dnl -----------------------------------------------------------
@@ -930,6 +927,15 @@ esac;
AM_CONDITIONAL(USE_PREBUILT_GLIBJ_ZIP, test x$use_glibj_zip = xtrue)
AC_SUBST(PATH_TO_GLIBJ_ZIP)
+# Check for javac if we need to build either the class library,
+# the examples or the tools
+if test "x${use_glibj_zip}" = xfalse || \
+ test "x${EXAMPLESDIR}" != x || \
+ test "x${TOOLSDIR}" != x; then
+ AC_PROG_JAVAC
+ CLASSPATH_JAVAC_MEM_CHECK
+fi
+
dnl -----------------------------------------------------------
dnl Build with Escher based X peers.
dnl -----------------------------------------------------------