summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDalibor Topic <robilad@yahoo.com>2007-06-24 23:45:39 +0000
committerDalibor Topic <robilad@yahoo.com>2007-06-24 23:45:39 +0000
commit6691a48bb95d5e3c92374263b9a406dce0c06087 (patch)
tree98e3eca24be8b5cbd08c44182f2a04bf5f2c74d2 /configure.ac
parent276bb091aabda35e0d39e497195f11926649bb42 (diff)
downloadclasspath-6691a48bb95d5e3c92374263b9a406dce0c06087.tar.gz
2007-06-25 Dalibor Topic <robilad@kaffe.org>
* configure.ac: Check for MSG_WAITALL, since it does not exist on Cygwin. * native/jni/java-nio/gnu_java_nio_VMChannel.c (Java_gnu_java_nio_VMChannel_receive): Define MSG_WAITALL as 0 if it does not exist.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d042fa500..94e8c9328 100644
--- a/configure.ac
+++ b/configure.ac
@@ -589,6 +589,17 @@ if test "x${COMPILE_JNI}" = xyes; then
[Define this symbol if you have SO_NOSIGPIPE]) ],
[ AC_MSG_RESULT(no)]
)
+ dnl **********************************************************************
+ dnl Check for MSG_WAITALL
+ dnl **********************************************************************
+ AC_MSG_CHECKING(for MSG_WAITALL)
+ AC_TRY_COMPILE([#include <sys/socket.h>],
+ [ int f = MSG_WAITALL; ],
+ [ AC_MSG_RESULT(yes)
+ AC_DEFINE(HAVE_MSG_WAITALL, 1,
+ [Define this symbol if you have MSG_WAITALL]) ],
+ [ AC_MSG_RESULT(no)]
+ )
dnl Check for plugin support headers and libraries.
if test "x${COMPILE_PLUGIN}" = xyes; then