summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMario Torre <neugens@limasoftware.net>2007-11-02 21:41:24 +0000
committerMario Torre <neugens@limasoftware.net>2007-11-02 21:41:24 +0000
commit7da7e85b15ca3ea128af6437033f443b881779ad (patch)
tree00eb8ec7c629011f179bb6f769268e4b479432b3 /configure.ac
parent74150ce539f8793b96b5e499ced499ed04e757e8 (diff)
downloadclasspath-7da7e85b15ca3ea128af6437033f443b881779ad.tar.gz
2007-11-01 Mario Torre <neugens@limasoftware.net>
PR classpath/33982: * configure.ac: add GDK_CFLAGS for the GStreamer peer.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 109f0153a..52161c63d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -534,7 +534,7 @@ if test "x${COMPILE_JNI}" = xyes; then
dnl compiled in
USE_GCONF_PREFS_PEER=$enable_default_preferences_peer
if test "$USE_GCONF_PREFS_PEER" = ""; then
- DEFAULT_PREFS_PEER=gnu.java.util.prefs.GConfBasedFactory
+ DEFAULT_PREFS_PEER=gnu.java.util.prefs.GConfBasedFactory
fi
fi
@@ -562,6 +562,10 @@ if test "x${COMPILE_JNI}" = xyes; then
GST_PLUGIN_LDFLAGS='-module -avoid-version -Wno-unused-parameter -no-undefined'
AC_SUBST(GST_PLUGIN_LDFLAGS)
+
+ PKG_CHECK_MODULES(GDK, gdk-2.0 >= 2.8)
+ AC_SUBST(GDK_CFLAGS)
+ AC_SUBST(GDK_LIBS)
dnl set the gstreamer based file reader, writer and mixer
GSTREAMER_FILE_READER=gnu.javax.sound.sampled.gstreamer.io.GstAudioFileReader