summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSteven Augart <augart@watson.ibm.com>2004-06-10 03:04:16 +0000
committerSteven Augart <augart@watson.ibm.com>2004-06-10 03:04:16 +0000
commit0ac4bf845cfe7fc4f657e42d3f2e1c0e4e5097e3 (patch)
tree165732427edef35ba1f6f18f51381b41de9330ff /configure.ac
parent3f62ac62d7084b2414100823f1c34795962a9bca (diff)
downloadclasspath-0ac4bf845cfe7fc4f657e42d3f2e1c0e4e5097e3.tar.gz
* configure.ac: Add SIZEOF_VOID_P to include/config.h.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c9d5a8116..a57d1d993 100644
--- a/configure.ac
+++ b/configure.ac
@@ -14,7 +14,7 @@ AC_CANONICAL_TARGET
dnl -----------------------------------------------------------
dnl Fold all IA-32 CPU architectures into "x86"
dnl -----------------------------------------------------------
-if expr ${target_cpu} : .*86 > /dev/null; then target_cpu=x86; fi
+if expr ${target_cpu} : '.*86' > /dev/null; then target_cpu=x86; fi
dnl -----------------------------------------------------------
dnl We will not track/change lib version until we reach version 1.0
@@ -98,6 +98,9 @@ AC_PROG_CPP
if test "x${COMPILE_JNI}" = xyes; then
AC_HEADER_STDC
+ dnl Checking sizeof void * is needed for fdlibm to work properly on ppc64,
+ dnl at least.
+ AC_CHECK_SIZEOF(void *)
dnl We check for sys/filio.h because Solaris 2.5 defines FIONREAD there.
dnl On that system, sys/ioctl.h will not include sys/filio.h unless
dnl BSD_COMP is defined; just including sys/filio.h is simpler.