summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDalibor Topic <robilad@yahoo.com>2006-04-02 20:55:33 +0000
committerDalibor Topic <robilad@yahoo.com>2006-04-02 20:55:33 +0000
commit2e50680946b3e82b86c2db8b5efbc9e651407d55 (patch)
tree101ea980c3d3d1b7bb42bd0cce5e85bdec67bca3 /configure.ac
parent9cdead1bd74a26f78c1e2d7650fafc80afc7b2f5 (diff)
downloadclasspath-2e50680946b3e82b86c2db8b5efbc9e651407d55.tar.gz
Added support for using a prebuilt glibj.zip
2006-04-02 Dalibor Topic <robilad@kaffe.org> * configure.ac (with-glibj-zip): Added new option. * examples/Makefile.am, lib/Makefile.am, tools/Makefile.am: Adapted build classpath to use glibj.zip, in addition to classes in lib directory.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 27 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 03d87ce39..b426b1f17 100644
--- a/configure.ac
+++ b/configure.ac
@@ -584,6 +584,33 @@ AC_ARG_ENABLE([portable-native-sync],
AX_CREATE_STDINT_H([include/config-int.h])
+dnl -----------------------------------------------------------------------
+dnl Support for using a prebuilt class library
+dnl -----------------------------------------------------------------------
+AC_ARG_WITH([glibj_zip],
+ AS_HELP_STRING([--with-glibj-zip=ABS.PATH],
+ [use prebuilt glibj.zip class library]))
+
+case "$with_glibj_zip" in
+"")
+ use_glibj_zip=false
+ ;;
+"no" )
+ use_glibj_zip=false
+ ;;
+"yes")
+ AC_MSG_ERROR([Please suply an absolute path to a prebuilt glibj.zip])
+ ;;
+*)
+ use_glibj_zip=true
+ PATH_TO_GLIBJ_ZIP=$with_glibj_zip
+ ;;
+esac;
+
+AM_CONDITIONAL(USE_PREBUILT_GLIBJ_ZIP, test x$use_glibj_zip = xtrue)
+AC_SUBST(PATH_TO_GLIBJ_ZIP)
+
+
dnl -----------------------------------------------------------
dnl output files
dnl -----------------------------------------------------------