summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Fitzsimmons <fitzsim@redhat.com>2006-05-09 18:11:12 +0000
committerThomas Fitzsimmons <fitzsim@redhat.com>2006-05-09 18:11:12 +0000
commit60e1fc7d605ea7c8cdc8c97630c103ccd025ff52 (patch)
treecdf5d54138fad5fd0e6c9ca65b34e60f9699bb33 /configure.ac
parent24a32787e38a8198e51d65177b21714e81e0de45 (diff)
downloadclasspath-60e1fc7d605ea7c8cdc8c97630c103ccd025ff52.tar.gz
2006-05-09 Thomas Fitzsimmons <fitzsim@redhat.com>
* configure.ac: Add --disable-plugin and --with-vm options. Check for plugin support headers and libraries. * native/Makefile.am: Recurse into plugin directory. * native/plugin/.cvsignore: New file. * native/plugin/Makefile.am: New file. * native/plugin/gcjwebplugin.cc: New file. * tools/Makefile.am: Install appletviewer wrapper script. * tools/appletviewer.in: Replace VM location heuristic with VM_BINARY configure substitution.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac42
1 files changed, 41 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d20f65e5d..75d5b1d8e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -195,12 +195,24 @@ AC_ARG_ENABLE([qt-peer],
[COMPILE_QT_PEER=no])
AM_CONDITIONAL(CREATE_QT_PEER_LIBRARIES, test "x${COMPILE_QT_PEER}" = xyes)
+dnl -----------------------------------------------------------
+dnl Plugin (enabled by default)
+dnl -----------------------------------------------------------
+AC_ARG_ENABLE([plugin],
+ [AS_HELP_STRING(--disable-plugin,compile gcjwebplugin (disabled by --disable-plugin) [default=yes])],
+ [case "${enableval}" in
+ yes) COMPILE_PLUGIN=yes ;;
+ no) COMPILE_PLUGIN=no ;;
+ *) COMPILE_PLUGIN=yes ;;
+ esac],
+ [COMPILE_PLUGIN=yes])
+AM_CONDITIONAL(CREATE_PLUGIN, test "x${COMPILE_PLUGIN}" = xyes)
dnl -----------------------------------------------------------
dnl Sets the native libraries installation dir
dnl -----------------------------------------------------------
AC_ARG_WITH([native-libdir],
- [AS_HELP_STRING(--with-native-libdir,sets the installation directore for native libraries [default='${libdir}/${PACKAGE}'])],
+ [AS_HELP_STRING(--with-native-libdir,sets the installation directory for native libraries [default='${libdir}/${PACKAGE}'])],
[
nativeexeclibdir=${withval}
],
@@ -225,6 +237,20 @@ AC_ARG_WITH([glibj-dir],
AC_SUBST(glibjdir)
dnl -----------------------------------------------------------
+dnl Sets the VM name for use in tool wrapper scripts
+dnl -----------------------------------------------------------
+AC_ARG_WITH([vm],
+ [AS_HELP_STRING(--with-vm,sets the VM binary name [default='${prefix}/bin/jamvm'])],
+ [
+ VM_BINARY=${withval}
+ ],
+ [
+ VM_BINARY='${prefix}/bin/jamvm'
+ ])
+
+AC_SUBST(VM_BINARY)
+
+dnl -----------------------------------------------------------
dnl Regenerate headers at build time (disabled by default)
dnl -----------------------------------------------------------
AC_ARG_ENABLE([regen-headers],
@@ -441,6 +467,19 @@ if test "x${COMPILE_JNI}" = xyes; then
AC_SUBST(QT_CFLAGS)
AC_SUBST(QT_LIBS)
fi
+
+ dnl Check for plugin support headers and libraries.
+ if test "x${COMPILE_PLUGIN}" = xyes; then
+ PKG_CHECK_MODULES(MOZILLA, mozilla-plugin)
+ PKG_CHECK_MODULES(GLIB, glib-2.0)
+
+ AC_SUBST(MOZILLA_CFLAGS)
+ AC_SUBST(MOZILLA_LIBS)
+ AC_SUBST(GLIB_CFLAGS)
+ AC_SUBST(GLIB_LIBS)
+
+ AC_SUBST(PLUGIN_DIR, $HOME/.mozilla/plugins/)
+ fi
fi
CLASSPATH_WITH_JAVAH
@@ -665,6 +704,7 @@ native/jni/qt-peer/Makefile
native/jni/xmlj/Makefile
native/jni/midi-alsa/Makefile
native/jni/midi-dssi/Makefile
+native/plugin/Makefile
native/target/Makefile
native/target/Linux/Makefile
native/target/generic/Makefile