summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Fitzsimmons <fitzsim@redhat.com>2006-05-27 21:10:46 +0000
committerThomas Fitzsimmons <fitzsim@redhat.com>2006-05-27 21:10:46 +0000
commit8688ded04094bfc01be2b4bae3bb4cf2c638f5e0 (patch)
treefde600d35f38e8d709c2461218010e61796e2a77 /configure.ac
parent6b3a4220ff51c40bb2bc217c275bc9cf7742a031 (diff)
downloadclasspath-8688ded04094bfc01be2b4bae3bb4cf2c638f5e0.tar.gz
2006-05-27 Thomas Fitzsimmons <fitzsim@redhat.com>
* configure.ac (FOUND_CACAO): New automake conditional. Add --enable-tool-wrappers. * NEWS: Introduce the --enable-tool-wrappers option. * tools/Makefile.am[CREATE_WRAPPERS]: Build wrapper binaries. * tools/appletviewer.c: Remove file. Make tool-indepedent and rename ... * tools/toolwrapper.c: New file.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 25 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index c4b8412dd..8132713a5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -232,6 +232,7 @@ AC_ARG_WITH([vm],
])
AC_SUBST(VM_BINARY)
+AM_CONDITIONAL(FOUND_CACAO, test "x`basename $VM_BINARY`" = xcacao)
dnl -----------------------------------------------------------
dnl Regenerate headers at build time (disabled by default)
@@ -246,6 +247,20 @@ AC_ARG_ENABLE([regen-headers],
[REGENERATE_JNI_HEADERS=no])
AM_CONDITIONAL(CREATE_JNI_HEADERS, test "x${REGENERATE_JNI_HEADERS}" = xyes)
+dnl -----------------------------------------------------------
+dnl Enable tool wrapper binaries (disabled by default)
+dnl -----------------------------------------------------------
+AC_ARG_ENABLE([tool-wrappers],
+ [AS_HELP_STRING(--enable-tool-wrappers,create tool wrapper binaries [default=no])],
+ [case x"${enableval}" in
+ xyes) COMPILE_WRAPPERS=yes ;;
+ xno) COMPILE_WRAPPERS=no ;;
+ x) COMPILE_WRAPPERS=yes ;;
+ *) COMPILE_WRAPPERS=yes ;;
+ esac],
+ [COMPILE_WRAPPERS=no])
+AM_CONDITIONAL(CREATE_WRAPPERS, test "x${COMPILE_WRAPPERS}" = xyes)
+
AC_PROG_LN_S
AC_PROG_INSTALL
@@ -695,15 +710,20 @@ scripts/classpath.spec
lib/Makefile
lib/gen-classlist.sh
lib/copy-vmresources.sh
-tools/appletviewer
tools/Makefile
-tools/jarsigner
-tools/keytool
examples/Makefile
examples/Makefile.jawt])
-AC_CONFIG_COMMANDS([gen-classlist],[chmod 755 lib/gen-classlist.sh])
-AC_CONFIG_COMMANDS([copy-vmresources],[chmod 755 lib/copy-vmresources.sh])
+
+if test "x${COMPILE_WRAPPERS}" = xno
+then
+AC_CONFIG_FILES([tools/appletviewer
+tools/jarsigner
+tools/keytool])
AC_CONFIG_COMMANDS([appletviewer],[chmod 755 tools/appletviewer])
AC_CONFIG_COMMANDS([jarsigner],[chmod 755 tools/jarsigner])
AC_CONFIG_COMMANDS([keytool],[chmod 755 tools/keytool])
+fi
+
+AC_CONFIG_COMMANDS([gen-classlist],[chmod 755 lib/gen-classlist.sh])
+AC_CONFIG_COMMANDS([copy-vmresources],[chmod 755 lib/copy-vmresources.sh])
AC_OUTPUT