summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrew John Hughes <gnu_andrew@member.fsf.org>2008-06-11 21:39:50 +0000
committerAndrew John Hughes <gnu_andrew@member.fsf.org>2008-06-11 21:39:50 +0000
commit6afe22839353b53c96ce084e8f959a6444f658d1 (patch)
treee480f984245da93e55f57329ddf5b474d7db05de /configure.ac
parent48aa4cbbe95580832414644c0138efafbee6c9f5 (diff)
downloadclasspath-6afe22839353b53c96ce084e8f959a6444f658d1.tar.gz
Forwardport native-only build fix #06.
2008-06-01 Andrew John Hughes <gnu_andrew@member.fsf.org> * configure.ac: Only regenerate headers by default if the headers aren't in the source tree.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a9cdab003..a4287e53e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -316,13 +316,17 @@ dnl -----------------------------------------------------------
dnl Regenerate headers at build time (disabled by default)
dnl -----------------------------------------------------------
AC_ARG_ENABLE([regen-headers],
- [AS_HELP_STRING(--enable-regen-headers,automatically regenerate JNI headers [default=yes])],
+ [AS_HELP_STRING(--enable-regen-headers,automatically regenerate JNI headers [default=yes if headers don't exist])],
[case "${enableval}" in
yes) REGENERATE_JNI_HEADERS=yes ;;
no) REGENERATE_JNI_HEADERS=no ;;
*) REGENERATE_JNI_HEADERS=yes ;;
esac],
- [REGENERATE_JNI_HEADERS=yes])
+ [if test -e include/java_lang_VMSystem.h; then
+ REGENERATE_JNI_HEADERS=no ;
+ else
+ REGENERATE_JNI_HEADERS=yes ;
+ fi])
AM_CONDITIONAL(CREATE_JNI_HEADERS, test "x${REGENERATE_JNI_HEADERS}" = xyes)
dnl -----------------------------------------------------------