summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrew John Hughes <gnu_andrew@member.fsf.org>2010-05-27 10:32:54 +0000
committerAndrew John Hughes <gnu_andrew@member.fsf.org>2010-05-27 10:32:54 +0000
commite6c6a0238291db27ccdaee229bda59d7981a3182 (patch)
tree8c17474ce357e3eea2aa57fc1f46b9e34249b809 /configure.ac
parent5281557e2f7bb61e2ddfc188540b76ffbb57d34e (diff)
downloadclasspath-e6c6a0238291db27ccdaee229bda59d7981a3182.tar.gz
Define macros only once and require dependencies rather than using inclusion.
2010-05-04 Andrew John Hughes <ahughes@redhat.com> * configure.ac: Call AC_PROG_JAVA_WORKS and AC_PROG_JAVAC_WORKS in place of AC_PROG_JAVA and AC_PROG_JAVAC respectively, as this is the real test we want. * m4/ac_prog_java.m4: (AC_PROG_JAVA): Don't include AC_PROG_JAVA_WORKS. * m4/ac_prog_java_works.m4: (AC_PROG_JAVA_WORKS): Require AC_PROG_JAVA and be defined only once. Require AC_PROG_JAVAC_WORKS for compilation of test class. Remove inclusion of AC_PROG_JAVAC. (AC_TRY_COMPILE_JAVA): Require AC_PROG_JAVAC_WORKS rather than AC_PROG_JAVAC. Be defined only once. * m4/ac_prog_javac.m: (AC_PROG_JAVAC): Be defined only once. Don't include AC_PROG_JAVAC_WORKS. * m4/ac_prog_javac_works.m4: (AC_PROG_JAVAC_WORKS): Be defined only once. Require AC_PROG_JAVAC.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 29fb0dd40..7f75a6ae6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -974,7 +974,7 @@ AC_SUBST(PATH_TO_GLIBJ_ZIP)
if test "x${TOOLSDIR}" != x; then
if test "x${COMPILE_WRAPPERS}" = xno; then
- AC_PROG_JAVA
+ AC_PROG_JAVA_WORKS
fi
if test "x${COMPILE_GJDOC}" = xyes; then
AC_LIB_ANTLR
@@ -990,7 +990,7 @@ if test "x${use_glibj_zip}" = xfalse || \
test "x${EXAMPLESDIR}" != x || \
test "x${TOOLSDIR}" != x && \
test "x${build_class_files}" != xno; then
- AC_PROG_JAVAC
+ AC_PROG_JAVAC_WORKS
CLASSPATH_JAVAC_MEM_CHECK
fi