summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorEric Blake <ebb9@byu.net>2002-03-28 20:38:06 +0000
committerEric Blake <ebb9@byu.net>2002-03-28 20:38:06 +0000
commitf7f178bb3f41670950a8dbd26f6b87c900cbfd86 (patch)
tree63444bf5db113f3e791cb6ac173972542c1fc60d /configure.in
parentd5b90075a216d7a0445ccb24b5b96b5c27f72006 (diff)
downloadclasspath-f7f178bb3f41670950a8dbd26f6b87c900cbfd86.tar.gz
2002-03-28 Eric Blake <ebb9@email.byu.edu>
* .cvsignore: Add autom4te.cache to ignored list. * configure.in: Move CLASSPATH_WITH_JAVAH and CLASSPATH_WITH_INCLUDEDIR out of conditionals, for use with latest autotools. Make variable tests consistent. * acinclude.m4: Make variable tests consistent.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 12 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index a932c66be..461a9a218 100644
--- a/configure.in
+++ b/configure.in
@@ -55,9 +55,9 @@ AC_ARG_ENABLE(cni,
esac],
[COMPILE_CNI=no])
-AM_CONDITIONAL(CREATE_JNI_HEADERS, test x$COMPILE_JNI = xyes)
-AM_CONDITIONAL(CREATE_JNI_LIBRARIES, test x$COMPILE_JNI = xyes)
-AM_CONDITIONAL(CREATE_CNI_LIBRARIES, test x$COMPILE_CNI = xyes)
+AM_CONDITIONAL(CREATE_JNI_HEADERS, test "x${COMPILE_JNI}" = xyes)
+AM_CONDITIONAL(CREATE_JNI_LIBRARIES, test "x${COMPILE_JNI}" = xyes)
+AM_CONDITIONAL(CREATE_CNI_LIBRARIES, test "x${COMPILE_CNI}" = xyes)
AC_PROG_LN_S
AC_PROG_INSTALL
@@ -73,7 +73,7 @@ dnl Checks for programs.
AC_PROG_CC
AC_PROG_CPP
-if test "${COMPILE_JNI}" = "yes"; then
+if test "x${COMPILE_JNI}" = xyes; then
AC_HEADER_STDC
AC_CHECK_HEADERS(unistd.h sys/types.h sys/config.h inttypes.h stdint.h)
AC_EGREP_HEADER(uint32_t, stdint.h, AC_DEFINE(HAVE_INT32_DEFINED))
@@ -103,7 +103,7 @@ if test "${COMPILE_JNI}" = "yes"; then
CFLAGS="-g"
dnl We want warnings, lots of warnings :-)
- if eval "test x$GCC = xyes"; then
+ if test "x${GCC}" = xyes; then
JAPHAR_GREP_CFLAGS(-Wall, [ CFLAGS="$CFLAGS -Wall" ])
fi
@@ -114,11 +114,13 @@ if test "${COMPILE_JNI}" = "yes"; then
dnl XXX Fix me when libart.m4 has the compile test fixed!
enable_libarttest=no
AM_PATH_LIBART(2.1.0,,exit 1)
+fi
- CLASSPATH_WITH_JAVAH
+CLASSPATH_WITH_JAVAH
- CLASSPATH_WITH_INCLUDEDIR
+CLASSPATH_WITH_INCLUDEDIR
+if test "x${COMPILE_JNI}" = xyes; then
AC_MSG_CHECKING("jni_md.h support")
if test -f ${srcdir}/include/jni_md-${target_cpu}-${target_os}.h; then
AC_MSG_RESULT("yes")
@@ -177,7 +179,7 @@ AC_ARG_ENABLE(load-library,
*) AC_MSG_ERROR(bad value ${enableval} for --enable-load-library) ;;
esac],
[
- if test "$COMPILE_CNI" = "yes"; then
+ if test "x${COMPILE_CNI}" = xyes; then
INIT_LOAD_LIBRARY="false"
else
INIT_LOAD_LIBRARY="true"
@@ -205,7 +207,7 @@ dnl -----------------------------------------------------------
dnl Create a link to the VM specific files we're compiling with
-if test x"$JVM_REFERENCE" = x; then
+if test "x${JVM_REFERENCE}" = x; then
JVM_REFERENCE=reference
fi
AC_LINK_FILES(vm/$JVM_REFERENCE, vm/current)
@@ -225,7 +227,7 @@ AC_PATH_PROG(ZIP, zip)
dnl AC_PATH_PROG(UNZIP, unzip)
dnl AC_PATH_PROG(PERL, perl)
-AM_CONDITIONAL(HAVE_ZIP, test x$ZIP != x)
+AM_CONDITIONAL(HAVE_ZIP, test "x${ZIP}" != x)
AC_OUTPUT(Makefile
com/Makefile