summaryrefslogtreecommitdiff
path: root/examples/Makefile.am
diff options
context:
space:
mode:
authorTom Tromey <tromey@redhat.com>2006-01-07 22:53:20 +0000
committerTom Tromey <tromey@redhat.com>2006-01-07 22:53:20 +0000
commitf5da8da201fdee9058ea86510881880952b5d293 (patch)
treedf6ccfb5d78771d0fa53278b1002f006fe0ede5d /examples/Makefile.am
parent9af3534c87f4b70d927802f5a6847614996259ef (diff)
downloadclasspath-f5da8da201fdee9058ea86510881880952b5d293.tar.gz
2006-01-07 Paul Jenner <psj@harker.dyndns.org>
Fixes bug #25711 * examples/Makefile.am: Corrected DESTDIR install paths.
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am22
1 files changed, 11 insertions, 11 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
index 341fc5e8e..db6cac0d6 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -53,25 +53,25 @@ install-data-local:
for file in $(ALL_EXAMPLE_FILES); do \
f=`echo $$file | cut -c$$srcdir_cnt-`; \
fdir=`dirname $$f`; \
- if test ! -d $(DESTDIR)/$(pkgdatadir)/examples/$$fdir; then \
- echo "$(mkinstalldirs) $(DESTDIR)/$(pkgdatadir)/examples/$$fdir"; \
- $(mkinstalldirs) $(DESTDIR)/$(pkgdatadir)/examples/$$fdir; \
+ if test ! -d $(DESTDIR)$(pkgdatadir)/examples/$$fdir; then \
+ echo "$(mkinstalldirs) $(DESTDIR)$(pkgdatadir)/examples/$$fdir"; \
+ $(mkinstalldirs) $(DESTDIR)$(pkgdatadir)/examples/$$fdir; \
fi; \
- echo "$(INSTALL_DATA) $$file $(DESTDIR)/$(pkgdatadir)/examples/$$f"; \
- $(INSTALL_DATA) $$file $(DESTDIR)/$(pkgdatadir)/examples/$$f; \
+ echo "$(INSTALL_DATA) $$file $(DESTDIR)$(pkgdatadir)/examples/$$f"; \
+ $(INSTALL_DATA) $$file $(DESTDIR)$(pkgdatadir)/examples/$$f; \
done
- echo "$(INSTALL_DATA) Makefile.jawt $(DESTDIR)/$(pkgdatadir)/examples/"
- $(INSTALL_DATA) Makefile.jawt $(DESTDIR)/$(pkgdatadir)/examples/
+ echo "$(INSTALL_DATA) Makefile.jawt $(DESTDIR)$(pkgdatadir)/examples/"
+ $(INSTALL_DATA) Makefile.jawt $(DESTDIR)$(pkgdatadir)/examples/
uninstall-local:
srcdir_cnt=`echo $(srcdir) | wc -c`; \
for file in $(ALL_EXAMPLE_FILES); do \
f=`echo $$file | cut -c$$srcdir_cnt-`; \
- echo "rm -f $(DESTDIR)/$(pkgdatadir)/examples/$$f"; \
- rm -f $(DESTDIR)/$(pkgdatadir)/examples/$$f; \
+ echo "rm -f $(DESTDIR)$(pkgdatadir)/examples/$$f"; \
+ rm -f $(DESTDIR)$(pkgdatadir)/examples/$$f; \
done
- echo "rm -f $(DESTDIR)/$(pkgdatadir)/examples/Makefile.jawt"
- rm -f $(DESTDIR)/$(pkgdatadir)/examples/Makefile.jawt
+ echo "rm -f $(DESTDIR)$(pkgdatadir)/examples/Makefile.jawt"
+ rm -f $(DESTDIR)$(pkgdatadir)/examples/Makefile.jawt
# Make sure everything is included in the distribution.
EXTRA_DIST = README Makefile.jawt.in