summaryrefslogtreecommitdiff
path: root/include/Makefile.am
diff options
context:
space:
mode:
authorAndrew John Hughes <gnu_andrew@member.fsf.org>2006-02-13 16:12:53 +0000
committerAndrew John Hughes <gnu_andrew@member.fsf.org>2006-02-13 16:12:53 +0000
commit0de22a37e228d7bb15b054f7faed3754f687041e (patch)
tree08036dd9df8988ea95c68fefea82e304756cb6cf /include/Makefile.am
parent44231862e521c7a1ee0182d73c836818ef43721c (diff)
downloadclasspath-0de22a37e228d7bb15b054f7faed3754f687041e.tar.gz
2006-02-13 Andrew John Hughes <gnu_andrew@member.fsf.org>
* include/Makefile.am: Swapped Math.h for VMMath.h * include/java_lang_Math.h: Removed. * include/java_lang_VMMath.h: New autogenerated header for the new class. * java/lang/Math.java: (sin(double)): Changed to link to VMMath. (cos(double)): Changed to link to VMMath. (tan(double)): Changed to link to VMMath. (asin(double)): Changed to link to VMMath. (acos(double)): Changed to link to VMMath. (atan(double)): Changed to link to VMMath. (atan2(double)): Changed to link to VMMath. (exp(double)): Changed to link to VMMath. (log(double)): Changed to link to VMMath. (sqrt(double)): Changed to link to VMMath. (pow(double,double)): Changed to link to VMMath. (IEEEremainder(double,double)): Changed to link to VMMath. (ceil(double)): Changed to link to VMMath. (floor(double)): Changed to link to VMMath. (rint(double)): Changed to link to VMMath. * native/jni/java-lang/Makefile.am: Replaced java_lang_Math.c with java_lang_VMMath.c * native/jni/java-lang/java_lang_Math.c: Removed. * native/jni/java-lang/java_lang_VMMath.c: Renamed from java_lang_Math.c. * vm/reference/java/lang/VMMath.java: New class. (sin(double)): New native method. (cos(double)): New native method. (tan(double)): New native method. (asin(double)): New native method. (acos(double)): New native method. (atan(double)): New native method. (atan2(double)): New native method. (exp(double)): New native method. (log(double)): New native method. (sqrt(double)): New native method. (pow(double,double)): New native method. (IEEEremainder(double,double)): New native method. (ceil(double)): New native method. (floor(double)): New native method. (rint(double)): New native method.
Diffstat (limited to 'include/Makefile.am')
-rw-r--r--include/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
index f829ba4ea..0517e125a 100644
--- a/include/Makefile.am
+++ b/include/Makefile.am
@@ -127,9 +127,9 @@ $(top_srcdir)/include/gnu_java_nio_charset_iconv_IconvDecoder.h \
$(top_srcdir)/include/java_io_VMFile.h \
$(top_srcdir)/include/java_io_VMObjectInputStream.h \
$(top_srcdir)/include/java_io_VMObjectStreamClass.h \
-$(top_srcdir)/include/java_lang_Math.h \
$(top_srcdir)/include/java_lang_VMDouble.h \
$(top_srcdir)/include/java_lang_VMFloat.h \
+$(top_srcdir)/include/java_lang_VMMath.h \
$(top_srcdir)/include/java_lang_VMProcess.h \
$(top_srcdir)/include/java_lang_VMSystem.h \
$(top_srcdir)/include/java_lang_reflect_Array.h \
@@ -178,8 +178,8 @@ $(top_srcdir)/include/java_io_VMObjectInputStream.h: $(top_srcdir)/vm/reference/
$(JAVAH) -o $@ java.io.VMObjectInputStream
$(top_srcdir)/include/java_io_VMObjectStreamClass.h: $(top_srcdir)/vm/reference/java/io/VMObjectStreamClass.java
$(JAVAH) -o $@ java.io.VMObjectStreamClass
-$(top_srcdir)/include/java_lang_Math.h: $(top_srcdir)/java/lang/Math.java
- $(JAVAH) -o $@ java.lang.Math
+$(top_srcdir)/include/java_lang_VMMath.h: $(top_srcdir)/vm/reference/java/lang/VMMath.java
+ $(JAVAH) -o $@ java.lang.VMMath
$(top_srcdir)/include/java_lang_VMDouble.h: $(top_srcdir)/vm/reference/java/lang/VMDouble.java
$(JAVAH) -o $@ java.lang.VMDouble
$(top_srcdir)/include/java_lang_VMFloat.h: $(top_srcdir)/vm/reference/java/lang/VMFloat.java