summaryrefslogtreecommitdiff
path: root/include/Makefile.am
diff options
context:
space:
mode:
authorMichael Koch <konqueror@gmx.de>2004-04-29 14:37:05 +0000
committerMichael Koch <konqueror@gmx.de>2004-04-29 14:37:05 +0000
commitd0c1f6c5c950da4558effb35d220b4fecac54746 (patch)
tree52d729dc8e2c4a79d2717d1f76c20e5a30c20b90 /include/Makefile.am
parentafad540966e7dbc11b90595e879d5ccefece7340 (diff)
downloadclasspath-d0c1f6c5c950da4558effb35d220b4fecac54746.tar.gz
2004-04-29 Michael Koch <konqueror@gmx.de>
* include/java_nio_MappedByteBufferImpl.h: New file. * include/Makefile.am: Generate java_nio_MappedByteBufferImpl.h. * native/jni/java-nio/gnu_java_nio_channels_FileChannelImpl.c (implTruncate): Fixed typo. * native/jni/java-nio/java_nio_MappedByteBufferImpl.c: New file. * native/jni/java-nio/Makefile.am: Compile java_nio_MappedByteBufferImpl.c.
Diffstat (limited to 'include/Makefile.am')
-rw-r--r--include/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
index cb04470f3..e18f7194f 100644
--- a/include/Makefile.am
+++ b/include/Makefile.am
@@ -56,6 +56,7 @@ $(top_srcdir)/include/java_lang_reflect_Array.h \
$(top_srcdir)/include/java_net_InetAddress.h \
$(top_srcdir)/include/java_net_NetworkInterface.h \
$(top_srcdir)/include/java_nio_DirectByteBufferImpl.h \
+$(top_srcdir)/include/java_nio_MappedByteBufferImpl.h \
$(top_srcdir)/include/java_util_TimeZone.h
if CREATE_JNI_HEADERS
@@ -166,6 +167,8 @@ $(top_srcdir)/include/java_net_NetworkInterface.h: $(top_srcdir)/java/net/Networ
$(JAVAH) -o $@ java.net.NetworkInterface
$(top_srcdir)/include/java_nio_DirectByteBufferImpl.h: $(top_srcdir)/java/nio/DirectByteBufferImpl.java
$(JAVAH) -o $@ java.nio.DirectByteBufferImpl
+$(top_srcdir)/include/java_nio_MappedByteBufferImpl.h: $(top_srcdir)/java/nio/MappedByteBufferImpl.java
+ $(JAVAH) -o $@ java.nio.MappedByteBufferImpl
$(top_srcdir)/include/gnu_java_nio_channels_FileChannelImpl.h: $(top_srcdir)/gnu/java/nio/channels/FileChannelImpl.java
$(JAVAH) -o $@ gnu.java.nio.channels.FileChannelImpl
$(top_srcdir)/include/java_util_TimeZone.h: $(top_srcdir)/java/util/TimeZone.java