summaryrefslogtreecommitdiff
path: root/include/Makefile.am
diff options
context:
space:
mode:
authorMichael Koch <konqueror@gmx.de>2004-11-21 11:03:45 +0000
committerMichael Koch <konqueror@gmx.de>2004-11-21 11:03:45 +0000
commite25a3477a8c8dba706ec00eff332df1d64dacb07 (patch)
treefdeaeee7a0bd5f176674a84bdb2192c9f3e64e2b /include/Makefile.am
parentd400879572214f15578b5b73d883cd3523da1501 (diff)
downloadclasspath-e25a3477a8c8dba706ec00eff332df1d64dacb07.tar.gz
2004-11-21 Michael Koch <konqueror@gmx.de>
* gnu/classpath/RawData.java: Made abstract. * gnu/classpath/RawData32.java, gnu/classpath/RawData64.java: New files. * include/Makefile.am: Don't generate java_nio_DirectByteBufferImpl.h anymore and generate java_nio_VMDirectByteBuffer.h now. * java/nio/DirectByteBufferImpl.java: Moved native methods to VMDirectByteBuffer. * java/nio/MappedByteBufferImpl.java: Use methods from VMDirectBteBuffer. * native/jni/java-nio/Makefile.am: Removed java_nio_DirectByteBufferImpl.c and added java_nio_VMDirectByteBuffer.c * include/java_nio_DirectByteBufferImpl.h, native/jni/java-nio/java_nio_DirectByteBufferImpl.c: Removed. * include/java_nio_VMDirectByteBuffer.h, * native/jni/java-nio/java_nio_VMDirectByteBuffer.c, * vm/reference/java/nio/VMDirectByteBuffer.java: New files.
Diffstat (limited to 'include/Makefile.am')
-rw-r--r--include/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
index 33335880e..bbe0e0c2a 100644
--- a/include/Makefile.am
+++ b/include/Makefile.am
@@ -62,7 +62,7 @@ $(top_srcdir)/include/java_lang_VMSystem.h \
$(top_srcdir)/include/java_lang_reflect_Array.h \
$(top_srcdir)/include/java_net_InetAddress.h \
$(top_srcdir)/include/java_net_NetworkInterface.h \
-$(top_srcdir)/include/java_nio_DirectByteBufferImpl.h \
+$(top_srcdir)/include/java_nio_VMDirectByteBuffer.h \
$(top_srcdir)/include/java_nio_MappedByteBufferImpl.h \
$(top_srcdir)/include/java_nio_channels_Channels.h \
$(top_srcdir)/include/java_util_VMTimeZone.h
@@ -183,8 +183,8 @@ $(top_srcdir)/include/java_net_InetAddress.h: $(top_srcdir)/java/net/InetAddress
$(JAVAH) -o $@ java.net.InetAddress
$(top_srcdir)/include/java_net_NetworkInterface.h: $(top_srcdir)/java/net/NetworkInterface.java
$(JAVAH) -o $@ java.net.NetworkInterface
-$(top_srcdir)/include/java_nio_DirectByteBufferImpl.h: $(top_srcdir)/java/nio/DirectByteBufferImpl.java
- $(JAVAH) -o $@ java.nio.DirectByteBufferImpl
+$(top_srcdir)/include/java_nio_VMDirectByteBuffer.h: $(top_srcdir)/vm/reference/java/nio/VMDirectByteBuffer.java
+ $(JAVAH) -o $@ java.nio.VMDirectByteBuffer
$(top_srcdir)/include/java_nio_MappedByteBufferImpl.h: $(top_srcdir)/java/nio/MappedByteBufferImpl.java
$(JAVAH) -o $@ java.nio.MappedByteBufferImpl
$(top_srcdir)/include/java_nio_channels_Channels.h: $(top_srcdir)/java/nio/channels/Channels.java