summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorAndrew John Hughes <gnu_andrew@member.fsf.org>2012-11-25 22:23:17 +0000
committerAndrew John Hughes <gnu_andrew@member.fsf.org>2012-11-25 22:23:17 +0000
commitee33a9b464499659a674b26243e57fa9a349ab47 (patch)
treee8793f8e0cad94c4af2e1e7dd56e30cf22bfe1fb /lib/Makefile.am
parent2779d6fe0f5dd175c54f7e415753b0224c593c03 (diff)
downloadclasspath-ee33a9b464499659a674b26243e57fa9a349ab47.tar.gz
Provide implementations of ForwardingFileObject and ForwardingJavaFileObject. Set source/target to 1.6 for @Override.
2012-11-25 Andrew John Hughes <gnu_andrew@member.fsf.org> * javax/tools/FileObject.java: Add missing comment in header. * javax/tools/ForwardingFileObject.java: New class. (fileObject): Added. (ForwardingFileObject(F)): Implemented. (delete()): Likewise. (getCharContent(boolean)): Likewise. (getLastModified()): Likewise. (getName()): Likewise. (openInputStream()): Likewise. (openOutputStream()): Likewise. (openReader(boolean)): Likewise. (openWriter()): Likewise. (toUri()): Likewise. * javax/tools/ForwardingJavaFileObject.java: New class. (ForwardingJavaFileObject(F)): Implemented. (getKind()): Likewise. (isNameCompatible(String,Kind)): Likewise. * lib/Makefile.am: Bump source/target to 1.6 to allow use of @Override on interface implementations. Signed-off-by: Andrew John Hughes <gnu_andrew@member.fsf.org>
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 50d1baa9b..97a8b6926 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -9,9 +9,9 @@ compile_classpath = $(vm_classes):$(top_srcdir):$(top_srcdir)/external/w3c_dom:$
# handling source to bytecode compiler programs like gcj, jikes and kjc
if GCJ_JAVAC
-JCOMPILER = $(JAVAC) $(JAVACFLAGS) -fsource=1.5 -ftarget=1.5 --bootclasspath='' --classpath=$(compile_classpath) -d . @classes
+JCOMPILER = $(JAVAC) $(JAVACFLAGS) -fsource=1.6 -ftarget=1.6 --bootclasspath='' --classpath=$(compile_classpath) -d . @classes
else
-JCOMPILER = $(JAVAC) $(JAVACFLAGS) $(JAVAC_MEM_OPT) -source 1.5 -target 1.5 -bootclasspath '' -classpath $(compile_classpath) -d . @classes
+JCOMPILER = $(JAVAC) $(JAVACFLAGS) $(JAVAC_MEM_OPT) -source 1.6 -target 1.6 -bootclasspath '' -classpath $(compile_classpath) -d . @classes
endif
if CREATE_COLLECTIONS