summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorTom Tromey <tromey@redhat.com>2005-08-22 21:04:34 +0000
committerTom Tromey <tromey@redhat.com>2005-08-22 21:04:34 +0000
commit38f85fb28281b9f56a84618540c534a37e82d907 (patch)
tree6de14a510d7b54fe9096cd85102d7ec1f29d2774 /lib/Makefile.am
parent8a47a147c0d63cf18e34cf7fbec6680a5c4d4865 (diff)
downloadclasspath-38f85fb28281b9f56a84618540c534a37e82d907.tar.gz
* lib/split-for-gcj.sh: Create Makefile.deps atomically.
* lib/gen-classlist.sh.in: Don't run split-for-gcj.sh. * lib/Makefile.gcj (Makefile.deps): New target. * lib/Makefile.am (compile-classes): Pass top_srcdir to Makefile.gcj.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index d499640e2..a363a9cc2 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -125,7 +125,9 @@ if FOUND_GCJ
## builds.
compile-classes: classes $(JAVA_SRCS) Makefile
$(MAKE) -f $(srcdir)/Makefile.gcj \
- GCJ='$(GCJ)' compile_classpath='$(top_builddir):$(compile_classpath)'
+ GCJ='$(GCJ)' \
+ compile_classpath='$(top_builddir):$(compile_classpath)' \
+ top_srcdir=$(top_srcdir)
else
compile-classes: classes $(JAVA_SRCS) Makefile
$(JAVAC)