summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorMark Wielaard <mark@klomp.org>2004-11-11 15:17:37 +0000
committerMark Wielaard <mark@klomp.org>2004-11-11 15:17:37 +0000
commit5510883ac663135761811a4406fb8f88eca39de8 (patch)
tree88c8727af200687f5ef05b192a5621538bb4795f /lib/Makefile.am
parent983882ca28e240ab6fb19d0db8039502847c0c4b (diff)
downloadclasspath-5510883ac663135761811a4406fb8f88eca39de8.tar.gz
* lib/gen-classlist.sh.in: Split in classes list in standard, awt
and standardx lists. * lib/Makefile.am (FOUND_GCJ): Split compilation in three parts. (CLEANFILES): Add classes.standard, classes.awt and classes.standardx.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index e9ef6333b..3e1f3456b 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -18,7 +18,9 @@ propertyfiles := $(shell cd $(top_srcdir)/resource && $(FIND) gnu java org -nam
# handling source to bytecode compiler programs like gcj, jikes and kjc
if FOUND_GCJ
-JAVAC = $(GCJ) --bootclasspath '' --classpath $(top_srcdir):$(top_srcdir)/vm/reference:.:$(USER_CLASSLIB) -C -d . @classes
+JAVAC = $(GCJ) --bootclasspath '' --classpath $(top_srcdir):$(top_srcdir)/vm/reference:.:$(USER_CLASSLIB) -C -d . @classes.standard \
+&& $(GCJ) -Wno-deprecated --bootclasspath '' --classpath $(top_srcdir):$(top_srcdir)/vm/reference:.:$(USER_CLASSLIB) -C -d . @classes.awt \
+&& $(GCJ) -Wno-deprecated --bootclasspath '' --classpath $(top_srcdir):$(top_srcdir)/vm/reference:.:$(USER_CLASSLIB) -C -d . @classes.standardx
else
if FOUND_JIKES
JAVAC = $(JIKES) +F -bootclasspath '' -extdirs '' -sourcepath '' --classpath $(top_srcdir):$(top_srcdir)/vm/reference:.:$(USER_CLASSLIB) -d . @classes
@@ -86,7 +88,8 @@ compile-classes: classes $(JAVA_SRCS) Makefile
touch compile-classes
EXTRA_DIST = standard.omit mkcollections.pl.in
-CLEANFILES = compile-classes resources classes glibj.zip classes.1 \
+CLEANFILES = compile-classes resources classes \
+ classes.standard classes.awt classes.standardx glibj.zip classes.1 \
$(JAVA_DEPEND)
clean-local: