summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorTom Tromey <tromey@redhat.com>2004-12-25 23:10:06 +0000
committerTom Tromey <tromey@redhat.com>2004-12-25 23:10:06 +0000
commit5cd62667d09b2caa9bee01019cea3d42f0fcf857 (patch)
treeed4d28074e635b30a4b16b8793d3327210a6fc1d /lib/Makefile.am
parent3d0e00b0ae27a432eba8714205a66866d48fcfd8 (diff)
downloadclasspath-5cd62667d09b2caa9bee01019cea3d42f0fcf857.tar.gz
* lib/Makefile.am (JAVAC): Handle GCJX.
(GCJ): Removed. (JIKES): Likewise. (USER_JABBA): Likewise. (USER_JAVAH): Likewise. (FIND): Likewise. (USER_CLASSLIB): Likewise. * examples/Makefile.am (JCOMPILER): Handle gcjx. (GCJ): Removed. (JIKES): Likewise. * acinclude.m4 (CLASSPATH_WITH_GCJX): New macro. (CLASSPATH_CHECK_GCJX): Likewise. (CLASSPATH_FIND_JAVAC): Use it.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am12
1 files changed, 4 insertions, 8 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index c9a2bd44e..e83515533 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -5,14 +5,6 @@ JAVA_DEPEND = java.dep
## this file and restart the make process again
sinclude $(JAVA_DEPEND)
-USER_CLASSLIB = @USER_CLASSLIB@
-
-GCJ = @GCJ@
-JIKES = @JIKES@
-USER_JABBA = @USER_JABBA@
-USER_JAVAH = @USER_JAVAH@
-FIND = @FIND@
-
propertydirs := $(shell cd $(top_srcdir)/resource && $(FIND) gnu java org -type d ! -name CVS -print)
propertyfiles := $(shell cd $(top_srcdir)/resource && $(FIND) gnu java org -name \*\.properties -print)
@@ -32,6 +24,10 @@ JAVAC = $(JIKES) +Pno-shadow +F -bootclasspath '' -extdirs '' -sourcepath '' --c
else
if FOUND_KJC
JAVAC = $(KJC) -classpath .:$(USER_CLASSLIB) -d . @classes
+else
+if FOUND_GCJX
+JAVAC = $(GCJX) -classpath .:$(USER_CLASSLIB) -d . @classes
+endif # FOUND_GCJX
endif # FOUND_KJC
endif # FOUND_GCJ
endif # FOUND_JIKES