summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorMichael Koch <konqueror@gmx.de>2005-05-19 06:45:03 +0000
committerMichael Koch <konqueror@gmx.de>2005-05-19 06:45:03 +0000
commit9b75b65a75e05255ad272355780a4157878d5773 (patch)
treed2751b7016e3ab3e4cbabfd4517fd80464412446 /lib/Makefile.am
parentcf7b3ee1cdbd93eadd9d54a943dc2945cdf332b3 (diff)
downloadclasspath-9b75b65a75e05255ad272355780a4157878d5773.tar.gz
2005-05-19 Michael Koch <konqueror@gmx.de>
* java/text/DateFormatSymbols.java (getStringArray): New method. (getZoneStrings): Likewise. (DateFormatSymbols): Load symbols from properties files. * java/util/Locale.java (getDisplayLanguage): Handle new way to load language names. (getDisplayCountry): Handle new way to load territory names. (getDisplayVariant): Handle new way to load variant names. * lib/Makefile.am, lib/gen-classlist.sh.in: No need to special case classes from gnu.java.locale anymore. * scripts/generate-locale-list.sh: Generate list from the new properties files. * LICENSE: Added license of locale data properties files.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 330941661..8ead127d3 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -14,12 +14,11 @@ compile_classpath = $(top_srcdir):$(top_srcdir)/vm/reference:$(top_srcdir)/exter
if FOUND_GCJ
JAVAC = $(GCJ) --bootclasspath '' --classpath $(compile_classpath) -C -d . @classes.standard \
&& $(GCJ) -Wno-deprecated --bootclasspath '' --classpath $(compile_classpath) -C -d . @classes.awt \
-&& $(GCJ) -Wno-deprecated --bootclasspath '' --classpath $(compile_classpath) -C -d . @classes.locale \
&& $(GCJ) -Wno-deprecated --bootclasspath '' --classpath $(compile_classpath) -C -d . @classes.xml \
&& $(GCJ) -Wno-deprecated --bootclasspath '' --classpath $(compile_classpath) -C -d . @classes.standardx
else
if FOUND_JIKES
-JAVAC = $(JIKES) +Pno-shadow +F -bootclasspath '' -extdirs '' -sourcepath '' --classpath $(compile_classpath) -d . @classes
+JAVAC = $(JIKES) -nowarn +Pno-shadow +F -bootclasspath '' -extdirs '' -sourcepath '' --classpath $(compile_classpath) -d . @classes
else
if FOUND_KJC
JAVAC = $(KJC) -classpath .:$(USER_CLASSLIB) -d . @classes
@@ -113,7 +112,7 @@ compile-classes: classes $(JAVA_SRCS) Makefile
EXTRA_DIST = standard.omit mkcollections.pl.in
CLEANFILES = compile-classes resources classes \
classes.standard classes.awt classes.standardx classes.xml \
- classes.locale glibj.zip classes.1 \
+ glibj.zip classes.1 \
$(top_builddir)/java/util/LocaleData.java \
$(JAVA_DEPEND)