summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorAndrew John Hughes <gnu_andrew@member.fsf.org>2005-02-07 02:32:37 +0000
committerAndrew John Hughes <gnu_andrew@member.fsf.org>2005-02-07 02:32:37 +0000
commite6cd44e0c0be8f502355c6853d9196c6e598b973 (patch)
treedf1ef9c96cb15a9688601f41e16e82ad5aa41b0b /lib/Makefile.am
parentbc06aa3889246cb2df9742430256ebaf7955ccdc (diff)
downloadclasspath-e6cd44e0c0be8f502355c6853d9196c6e598b973.tar.gz
2005-02-07 Andrew John Hughes <gnu_andrew@member.fsf.org>
* acinclude.m4: (CLASSPATH_FIND_JAVAC): Add ECJ option. (CLASSPATH_WITH_ECJ): New function. (CLASSPATH_CHECK_ECJ): New function. * examples/Makefile.am: Allow examples to be built with ecj. * lib/Makefile.am: Allow Classpath to be built with ecj.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 2a950c16a..30c4e428a 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -26,6 +26,10 @@ JAVAC = $(KJC) -classpath .:$(USER_CLASSLIB) -d . @classes
else
if FOUND_GCJX
JAVAC = $(GCJX) -classpath .:$(USER_CLASSLIB) -d . @classes
+else
+if FOUND_ECJ
+JAVAC = $(ECJ) -warn:-deprecation,serial -proceedOnError -bootclasspath '' -classpath $(compile_classpath) -d . @classes
+endif # FOUND_ECJ
endif # FOUND_GCJX
endif # FOUND_KJC
endif # FOUND_GCJ