summaryrefslogtreecommitdiff
path: root/native/Makefile.am
diff options
context:
space:
mode:
authorBrian Jones <cbj@gnu.org>2001-10-27 18:31:26 +0000
committerBrian Jones <cbj@gnu.org>2001-10-27 18:31:26 +0000
commit4c36d7874bf8bd207b3cdb2554a10d409e5e936f (patch)
tree88c343b674e6eb86da798cd415c7f1ef9a74d5af /native/Makefile.am
parentdfc2a9e300bd0008a00bb8f479e40566f88bed65 (diff)
downloadclasspath-4c36d7874bf8bd207b3cdb2554a10d409e5e936f.tar.gz
* gnu/java/text/.cvsignore: new file
* lib/.cvsignore: added com * acinclude.m4: renamed CLASSPATH_INTERNAL_CHECK_JAPHAR to CLASSPATH_CHECK_JAPHAR renamed CLASSPATH_INTERNAL_CHECK_KAFFE to CLASSPATH_CHECK_KAFFE renamed CLASSPATH_CHECK_JAPHAR to CLASSPATH_WITH_JAPHAR renamed CLASSPATH_CHECK_KAFFE to CLASSPATH_WITH_KAFFE added CLASSPATH_FIND_JAVAC and supporting functions re-arranged, support for gcj added added CLASSPATH_FIND_JAVA and supporting functions added CLASSPATH_WITH_JAVAH and supporting functions added CLASSPATH_WITH_CLASSLIB added CLASSPATH_WITH_INCLUDEDIR * configure.in: use AC_CANONICAL_SYSTEM instead of AC_CANONICAL_HOST version changed to 0.03 added --enable-java (always by default) added --enable-jni (not built by default) added --enable-cni (not built by default, currently not implemented) added automake conditional CREATE_JNI_HEADERS, if true then build JNI headers added automake conditional CREATE_JNI_LIBRARIES, if true then build JNI native libraries added automake conditional CREATE_CNI_LIBRARIES, if true then build CNI native libraries, currently not implemented moved checks related to building JNI libraries so they are avoided when not building JNI libraries added AC_CYGWIN and AC_MINGW32 tests when building JNI libraries removed JVM specific checks moved --with-java, --with-javah, --with-classlib, --with-includedir macros to acinclude.m4 removed --enable-developer-mode added macro call to link jni_md.h added jni.h to OUTPUT to place it in ${top_builddir}/include easily handled INIT_LOAD_LIBRARY appropriately when --enable-cni is used * lib/Makefile.am: centralized definition of configured variables remove Sun's javac cruft simply definition of various tool argument definitions added gcj support avoid creating JNI headers unless --enable-jni used with configure fixup maintainer clean target * lib/genclasslist.sh.in: added com, avoid duplicates when top_srcdir equals top_builddir, causes gcj problems otherwise * native/Makefile.am: redefine subdirs in terms of --enable-jni or --enable-cni * native/jni/Makefile.am: removed JVM specific rules * native/jni/fdlibm.h: include stdlib.h (for NULL) * native/jni/java_lang_System.c: include stdlib.h (for NULL) * native/jni/awt/Makefile.am: removed JVM specific rules * native/lib/Makefile.am: removed JVM specific rules * vm/Makefile.am: removed JVM specific SUBDIRS definition
Diffstat (limited to 'native/Makefile.am')
-rw-r--r--native/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/native/Makefile.am b/native/Makefile.am
index abaecae72..a459aefb5 100644
--- a/native/Makefile.am
+++ b/native/Makefile.am
@@ -1,5 +1,13 @@
## Input file for automake to generate the Makefile.in used by configure
+if CREATE_JNI_LIBRARIES
SUBDIRS = jni lib vmi
-##java.lang java.net java.io java.lang.reflect java.util lib vmi gnu.java.awt.peer.gtk
+else
+if CREATE_CNI_LIBRARIES
+SUBDIRS = cni
+else
+SUBDIRS =
+endif
+endif
+