summaryrefslogtreecommitdiff
path: root/native/jni/midi-dssi/Makefile.am
diff options
context:
space:
mode:
authorAndrew John Hughes <gnu_andrew@member.fsf.org>2006-11-29 22:43:35 +0000
committerAndrew John Hughes <gnu_andrew@member.fsf.org>2006-11-29 22:43:35 +0000
commit3be294e0e9f07e379e1499b9868db9855eb8726f (patch)
treea1f67d3f1469ecc142b11c30b1e3c2e1a624794d /native/jni/midi-dssi/Makefile.am
parentf40b961c6c82ebc9ae9863635e5fe19c0b07c116 (diff)
downloadclasspath-3be294e0e9f07e379e1499b9868db9855eb8726f.tar.gz
2006-11-29 Andrew John Hughes <gnu_andrew@member.fsf.org>
* Merge of HEAD-->generics for 2006/11/12-2006/11/29.
Diffstat (limited to 'native/jni/midi-dssi/Makefile.am')
-rw-r--r--native/jni/midi-dssi/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/native/jni/midi-dssi/Makefile.am b/native/jni/midi-dssi/Makefile.am
index 48c8051cc..692579d46 100644
--- a/native/jni/midi-dssi/Makefile.am
+++ b/native/jni/midi-dssi/Makefile.am
@@ -9,4 +9,7 @@ libgjsmdssi_la_LDFLAGS = -avoid-version
AM_LDFLAGS = @CLASSPATH_MODULE@
AM_CPPFLAGS = @CLASSPATH_INCLUDES@
-AM_CFLAGS = @WARNING_CFLAGS@ @STRICT_WARNING_CFLAGS@ @ERROR_CFLAGS@
+# No STRICT_WARNING_CFLAGS here as we use dlsym to load the address of
+# a function,and ISO C prohibits casting void pointers, like those returned
+# by dlsym, to function pointers.
+AM_CFLAGS = @WARNING_CFLAGS@ @ERROR_CFLAGS@