summaryrefslogtreecommitdiff
path: root/native/plugin/Makefile.am
diff options
context:
space:
mode:
authorLillian Angel <langel@redhat.com>2006-06-05 14:19:59 +0000
committerLillian Angel <langel@redhat.com>2006-06-05 14:19:59 +0000
commit594585c661bbb7df3d5acba757fb119290d37101 (patch)
tree8d01607241181b94596ea53ee4373f00e75a0361 /native/plugin/Makefile.am
parent9ecd11093f39307edf88a661b0635cacb000453b (diff)
downloadclasspath-594585c661bbb7df3d5acba757fb119290d37101.tar.gz
2006-06-05 Lillian Angel <langel@redhat.com>
* native/plugin/Makefile.am: Fixed to use a set plugin directory in the .mozilla directory. All applet logs are now stored here, instead of /tmp. * native/plugin/gcjwebplugin.cc: Added new fields for security warning. (GCJ_NEW): Added code to generate a security warning for all pages that spawn an appletviewer. This warning asks the user if they trust the applet and if they would like to add it to a 'whitelist'. This whitelist keeps track of all the addresses the user would like to trust indefinitely. (plugin_user_trusts_documentbase): New helper function. (plugin_add_documentbase_to_whitelist): New helper function. (plugin_ask_user_about_documentbase): New helper function. (plugin_in_pipe_callback): Fixed check to determine if channel_error has been set. (plugin_start_appletviewer): Likewise. (plugin_create_applet_tag): Reset all fields to null after they have been freed. (plugin_send_message_to_appletviewer): Fixed all error checks to determine if channel_error has been set. (plugin_stop_appletviewer): Likewise. (NP_Initialize): Likewise. Also, added code to determine if directory and file should be created.
Diffstat (limited to 'native/plugin/Makefile.am')
-rw-r--r--native/plugin/Makefile.am15
1 files changed, 8 insertions, 7 deletions
diff --git a/native/plugin/Makefile.am b/native/plugin/Makefile.am
index 7358381eb..19c7618d8 100644
--- a/native/plugin/Makefile.am
+++ b/native/plugin/Makefile.am
@@ -4,15 +4,16 @@ libgcjwebplugin_la_SOURCES = gcjwebplugin.cc
libgcjwebplugin_la_CXXFLAGS = \
-Wall -DAPPLETVIEWER_EXECUTABLE="\"$(bindir)/appletviewer\"" \
- $(MOZILLA_CFLAGS) $(GLIB_CFLAGS)
+ -DPLUGIN_DATA_DIRECTORY="\"$(PLUGIN_DIR)/gcjwebplugin-data\"" \
+ $(MOZILLA_CFLAGS) $(GLIB_CFLAGS) $(GTK_CFLAGS)
libgcjwebplugin_la_LDFLAGS = -avoid-version \
- $(GLIB_LIBS) \
+ $(GLIB_LIBS) $(GTK_LIBS) \
-lstdc++
-install-libLTLIBRARIES: $(lib_LTLIBRARIES)
- $(INSTALL) -d -m0755 $(DESTDIR)@PLUGIN_DIR@
- $(INSTALL) .libs/libgcjwebplugin.so $(DESTDIR)@PLUGIN_DIR@
+install-plugin: $(lib_LTLIBRARIES)
+ $(INSTALL) -d -m0755 $(DESTDIR)$(PLUGIN_DIR)
+ $(INSTALL) .libs/libgcjwebplugin.so $(DESTDIR)$(PLUGIN_DIR)
-uninstall-libLTLIBRARIES:
- rm -f $(DESTDIR)@PLUGIN_DIR@/libgcjwebplugin.so
+uninstall-plugin:
+ rm -f $(DESTDIR)$(PLUGIN_DIR)/libgcjwebplugin.so