summaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorAudrius Meskauskas <audriusa@Bioinformatics.org>2006-02-09 20:22:07 +0000
committerAudrius Meskauskas <audriusa@Bioinformatics.org>2006-02-09 20:22:07 +0000
commiteb9aa9ad4129ac88dd0c053c9a87b836deea3ab2 (patch)
tree67cc83a51a175c23de86892399844e1f71efc48f /tools/Makefile.am
parent7b3d0a185c34dd45b4a3d410e3cf10b6f42732d0 (diff)
downloadclasspath-eb9aa9ad4129ac88dd0c053c9a87b836deea3ab2.tar.gz
2006-02-09 Audrius Meskauskas <AudriusA@Bioinformatics.org>
* tools/Makefile.am: Add tools/gnu/classpath/tools/rmi folder. * tools/gnu/classpath/tools/giop/GRMIC.txt: Explain it called from RMIC. * tools/gnu/classpath/tools/giop/grmic/Generator.java (getResource): Better diagnostic. * tools/gnu/classpath/tools/giop/grmic/GiopRmicCompiler.java: Rewritten. * tools/gnu/classpath/tools/giop/grmic/MethodGenerator.java: Implement AbstractMethodGenerator. * tools/gnu/classpath/tools/AbstractMethodGenerator.java, tools/gnu/classpath/tools/rmi/RMIC.java, tools/gnu/classpath/tools/rmi/RMIC.txt, tools/gnu/classpath/tools/rmi/rmic/RmiMethodGenerator.java, tools/gnu/classpath/tools/rmi/rmic/RmicCompiler.java, tools/gnu/classpath/tools/rmi/rmic/WrapUnWrapper.java, tools/gnu/classpath/tools/rmi/rmic/templates/Stub_12.jav, tools/gnu/classpath/tools/rmi/rmic/templates/Stub_12Method.jav, tools/gnu/classpath/tools/rmi/rmic/templates/Stub_12MethodVoid.jav: New files. * NEWS: Corrected entry about the tools.
Diffstat (limited to 'tools/Makefile.am')
-rwxr-xr-xtools/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index 128a299d6..3d9a49d26 100755
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -29,8 +29,9 @@ TOOLS_ZIP = tools.zip
# Extra objects that will not exist until configure-time
BUILT_SOURCES = $(TOOLS_ZIP)
-# the templates that must be included into the generated zip file
-TOOLS_TEMPLATES = $(srcdir)/gnu/classpath/tools/giop/grmic/templates/*.jav
+# The templates that must be included into the generated zip file.
+# This covers both tools/giop/grmic/templates and tools/rmi/rmic/templates:
+TOOLS_TEMPLATES = $(srcdir)/gnu/classpath/tools/*/*/templates/*.jav
TOOLS_HELPS = $(srcdir)/gnu/classpath/tools/giop/*.txt
# The tool specific README files.
@@ -88,7 +89,7 @@ dist-hook:
# And copy the template files we use to the classes dir so they get also included.
$(TOOLS_ZIP): $(TOOLS_JAVA_FILES)
mkdir -p classes/gnu/classpath/tools/giop/grmic/templates
- cp $(TOOLS_TEMPLATES) classes/gnu/classpath/tools/giop/grmic/templates
+ cp $(TOOLS_TEMPLATES) classes/gnu/classpath/tools/*/*/templates
cp $(TOOLS_HELPS) classes/gnu/classpath/tools/giop/
$(JCOMPILER) -d classes $(TOOLS_JAVA_FILES)
(cd classes; \