summaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorChristian Thalinger <twisti@complang.tuwien.ac.at>2006-12-15 22:09:28 +0000
committerChristian Thalinger <twisti@complang.tuwien.ac.at>2006-12-15 22:09:28 +0000
commitd8d222724fcb81a7aa8e1c6d5a4337c179a0ae01 (patch)
tree37bd908ab3012c54dee11048c01ae2d5e77f89f6 /tools/Makefile.am
parent413dee3ced2f6f4c653e36a49103706c4f14f255 (diff)
downloadclasspath-d8d222724fcb81a7aa8e1c6d5a4337c179a0ae01.tar.gz
2006-12-15 Christian Thalinger <twisti@complang.tuwien.ac.at>
* m4/acinclude.m4 (CLASSPATH_FIND_JAVAC): Added support for Sun's javac. (CLASSPATH_WITH_JAVAC): Added. (CLASSPATH_CHECK_JAVAC): Likewise. * lib/Makefile.am (JAVAC): Renamed to JCOMPILER. (FOUND_JAVAC): Added support for Sun's javac. * examples/Makefile.am: Likewise. * tools/Makefile.am: Likewise.
Diffstat (limited to 'tools/Makefile.am')
-rwxr-xr-xtools/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index 2e1f88002..5d68c7d93 100755
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -7,8 +7,12 @@ GLIBJ_CLASSPATH=asm
if FOUND_ECJ
JCOMPILER = $(ECJ) -1.5 -encoding UTF-8 -bootclasspath $(GLIBJ_BOOTCLASSPATH) -classpath .:$(GLIBJ_CLASSPATH)
else
+if FOUND_JAVAC
+JCOMPILER = $(JAVAC) -encoding UTF-8 -bootclasspath $(GLIBJ_BOOTCLASSPATH) -classpath .:$(GLIBJ_CLASSPATH)
+else
error dunno how to setup the JCOMPILER and compile
endif
+endif
if CREATE_WRAPPERS
bin_SCRIPTS =