summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f9105e909..a106e1166 100644
--- a/configure.ac
+++ b/configure.ac
@@ -440,13 +440,15 @@ if test "x${COMPILE_JNI}" = xyes; then
AC_EGREP_HEADER(u_int32_t, sys/types.h, AC_DEFINE(HAVE_BSD_INT32_DEFINED, 1, [Define to 1 if you have BSD u_int32_t]))
AC_EGREP_HEADER(u_int32_t, sys/config.h, AC_DEFINE(HAVE_BSD_INT32_DEFINED, 1, [Define to 1 if you have BSD u_int32_t]))
+ AC_SEARCH_LIBS([clock_gettime], [rt])
AC_SEARCH_LIBS([inet_pton],[nsl])
AC_CHECK_LIB([socket], [gethostname])
+
AC_CHECK_FUNCS([ftruncate fsync select \
gethostname socket strerror fork pipe execve open close \
lseek fstat read readv write writev htonl memset htons connect \
getsockname getpeername bind listen accept \
- recvfrom send sendto setsockopt getsockopt time mktime \
+ recvfrom send sendto setsockopt getsockopt time mktime clock_gettime \
gethostbyname_r localtime_r \
strerror_r \
fcntl \