summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index cb4c91ec3..9d4cee4ea 100644
--- a/configure.ac
+++ b/configure.ac
@@ -30,6 +30,17 @@ case "$host_os" in
;;
esac
+dnl get the target for the native layer
+case "$target_os" in
+ linux* )
+ TARGET=Linux
+ ;;
+ * )
+ TARGET=generic
+ ;;
+esac
+AC_SUBST(TARGET)
+
CLASSPATH_MODULE="${cp_module} -version-info ${LIBVERSION} -no-undefined"
AC_SUBST(CLASSPATH_MODULE)
@@ -277,6 +288,8 @@ if test "x${COMPILE_JNI}" = xyes; then
AC_STRUCT_TM
AC_STRUCT_TIMEZONE
+ TYPE_SOCKLEN_T
+
AC_MSG_CHECKING([for tm_gmtoff in struct tm])
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <time.h>]],[[struct tm tim; tim.tm_gmtoff = 0;]])],
[AC_DEFINE(STRUCT_TM_HAS_GMTOFF, 1, [Define if struct tm has tm_gmtoff field.])