summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index e9ef6333b..3e1f3456b 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -18,7 +18,9 @@ propertyfiles := $(shell cd $(top_srcdir)/resource && $(FIND) gnu java org -nam
# handling source to bytecode compiler programs like gcj, jikes and kjc
if FOUND_GCJ
-JAVAC = $(GCJ) --bootclasspath '' --classpath $(top_srcdir):$(top_srcdir)/vm/reference:.:$(USER_CLASSLIB) -C -d . @classes
+JAVAC = $(GCJ) --bootclasspath '' --classpath $(top_srcdir):$(top_srcdir)/vm/reference:.:$(USER_CLASSLIB) -C -d . @classes.standard \
+&& $(GCJ) -Wno-deprecated --bootclasspath '' --classpath $(top_srcdir):$(top_srcdir)/vm/reference:.:$(USER_CLASSLIB) -C -d . @classes.awt \
+&& $(GCJ) -Wno-deprecated --bootclasspath '' --classpath $(top_srcdir):$(top_srcdir)/vm/reference:.:$(USER_CLASSLIB) -C -d . @classes.standardx
else
if FOUND_JIKES
JAVAC = $(JIKES) +F -bootclasspath '' -extdirs '' -sourcepath '' --classpath $(top_srcdir):$(top_srcdir)/vm/reference:.:$(USER_CLASSLIB) -d . @classes
@@ -86,7 +88,8 @@ compile-classes: classes $(JAVA_SRCS) Makefile
touch compile-classes
EXTRA_DIST = standard.omit mkcollections.pl.in
-CLEANFILES = compile-classes resources classes glibj.zip classes.1 \
+CLEANFILES = compile-classes resources classes \
+ classes.standard classes.awt classes.standardx glibj.zip classes.1 \
$(JAVA_DEPEND)
clean-local: