summaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/Makefile.am')
-rwxr-xr-xtools/Makefile.am10
1 files changed, 1 insertions, 9 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index f63c63166..d6724ef60 100755
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -4,15 +4,7 @@ GLIBJ_BOOTCLASSPATH='$(top_builddir)/lib/glibj.zip'
GLIBJ_CLASSPATH=asm
# Setup the compiler to use the GNU Classpath library we just built.
-if FOUND_ECJ
-JCOMPILER = $(ECJ) -1.5 -encoding UTF-8 -warn:-deprecation,serial,typeHiding,unchecked,unused,varargsCast -bootclasspath $(GLIBJ_BOOTCLASSPATH) -classpath .:$(GLIBJ_CLASSPATH)
-else
-if FOUND_JAVAC
-JCOMPILER = $(JAVAC) -encoding UTF-8 -bootclasspath $(GLIBJ_BOOTCLASSPATH) -classpath $(GLIBJ_CLASSPATH)
-else
-error dunno how to setup the JCOMPILER and compile
-endif
-endif
+JCOMPILER = $(JAVAC) $(JAVACFLAGS) -source 1.5 -target 1.5 -encoding UTF-8 -bootclasspath $(GLIBJ_BOOTCLASSPATH) -classpath $(GLIBJ_CLASSPATH)
if CREATE_WRAPPERS
bin_SCRIPTS =