summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2011-12-20 13:21:51 -0500
committerBrad King <brad.king@kitware.com>2011-12-23 16:04:58 -0500
commit504660ea706e4232623adedc0e6b33f91471ea31 (patch)
treeb1a887a99734337f1177487b9b7225bfe29183a3 /CMakeLists.txt
parentffdb37a4f7321a7be1948c0b47fb80d448da97f5 (diff)
downloadcmake-504660ea706e4232623adedc0e6b33f91471ea31.tar.gz
Configure libarchive build within CMake
Re-enable the option to build libarchive within CMake now that we have imported a new snapshot. Force libarchive ENABLE_* cache options to the values CMake needs. Set ENABLE_OPENSSL based on CMAKE_USE_OPENSSL to preserve the behavior introduced in commit ee55a4f7 (Use OpenSSL only if CMAKE_USE_OPENSSL, 2011-02-08).
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1260cd6e6b..0091af3100 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -270,7 +270,7 @@ MACRO (CMAKE_BUILD_UTILITIES)
SET(CMAKE_ZLIB_INCLUDES ${ZLIB_INCLUDE_DIR})
SET(CMAKE_ZLIB_LIBRARIES ${ZLIB_LIBRARIES})
ELSE(CMAKE_USE_SYSTEM_ZLIB)
- SET(CMAKE_ZLIB_INCLUDES)
+ SET(CMAKE_ZLIB_INCLUDES ${CMake_SOURCE_DIR}/Utilities)
SET(CMAKE_ZLIB_LIBRARIES cmzlib)
ADD_SUBDIRECTORY(Utilities/cmzlib)
CMAKE_SET_TARGET_FOLDER(cmzlib "Utilities/3rdParty")
@@ -336,14 +336,14 @@ MACRO (CMAKE_BUILD_UTILITIES)
SET(CMAKE_TAR_INCLUDES ${LibArchive_INCLUDE_DIRS})
SET(CMAKE_TAR_LIBRARIES ${LibArchive_LIBRARIES})
ELSE(CMAKE_USE_SYSTEM_LIBARCHIVE)
- MESSAGE(FATAL_ERROR "Please enable CMAKE_USE_SYSTEM_LIBARCHIVE")
- SET(HAVE_LIBZ 1)
- SET(HAVE_ZLIB_H 1)
SET(ZLIB_INCLUDE_DIR ${CMAKE_ZLIB_INCLUDES})
- SET(ZLIB_LIBRARIES ${CMAKE_ZLIB_LIBRARIES})
SET(ZLIB_LIBRARY ${CMAKE_ZLIB_LIBRARIES})
- SET(BUILD_ARCHIVE_WITHIN_CMAKE TRUE)
ADD_DEFINITIONS(-DLIBARCHIVE_STATIC)
+ SET(ENABLE_NETTLE OFF CACHE INTERNAL "Enable use of Nettle")
+ SET(ENABLE_OPENSSL ${CMAKE_USE_OPENSSL} CACHE INTERNAL "Enable use of OpenSSL")
+ SET(ENABLE_XATTR OFF CACHE INTERNAL "Enable extended attribute support")
+ SET(ENABLE_ACL OFF CACHE INTERNAL "Enable ACL support")
+ SET(ENABLE_ICONV OFF CACHE INTERNAL "Enable iconv support")
ADD_SUBDIRECTORY(Utilities/cmlibarchive)
CMAKE_SET_TARGET_FOLDER(cmlibarchive "Utilities/3rdParty")
SET(CMAKE_TAR_LIBRARIES cmlibarchive ${BZIP2_LIBRARIES})