summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2011-03-31 16:59:03 -0400
committerBrad King <brad.king@kitware.com>2011-03-31 16:59:03 -0400
commit9c78ef13951de5a4b648823bb574e9436e6b7504 (patch)
tree2e75fd15cc5e8fb6d1bca5a4ee85c2b38670ded0 /CMakeLists.txt
parent148b528f9d7d991dc01f277624df4a8aa41feccc (diff)
downloadcmake-9c78ef13951de5a4b648823bb574e9436e6b7504.tar.gz
COMP: Fix build against non-standard outside libarchive
Use the include directories reported by find_package(LibArchive).
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c40bc2690b..93822ef0e4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -325,6 +325,7 @@ MACRO (CMAKE_BUILD_UTILITIES)
IF(NOT LibArchive_FOUND)
MESSAGE(FATAL_ERROR "CMAKE_USE_SYSTEM_LIBARCHIVE is ON but LibArchive is not found!")
ENDIF()
+ SET(CMAKE_TAR_INCLUDES ${LibArchive_INCLUDE_DIRS})
SET(CMAKE_TAR_LIBRARIES ${LibArchive_LIBRARIES})
ELSE(CMAKE_USE_SYSTEM_LIBARCHIVE)
SET(HAVE_LIBZ 1)