summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Cole <david.cole@kitware.com>2012-01-09 14:10:01 -0500
committerCMake Topic Stage <kwrobot@kitware.com>2012-01-09 14:10:01 -0500
commit5a5c32e1f22cae3cdba3e5be142ee84b9e4a8d4d (patch)
tree7ac1ebd509d98ed93d796ce3bf0be1778a20dfe5 /CMakeLists.txt
parente1c07a4342b719b982ffa099d930d2e193591114 (diff)
parent6c611c6b94ef54cbfdc81a1f049032f13a0ef024 (diff)
downloadcmake-5a5c32e1f22cae3cdba3e5be142ee84b9e4a8d4d.tar.gz
Merge topic 'update-libarchive'
6c611c6 libarchive: Restore CMake 2.6.3 as minimum version 2f5b677 libarchive: Update README-CMake.txt for new snapshot 156cb3b Merge branch 'libarchive-upstream' into update-libarchive fd42bf1 libarchive: Set .gitattributes to allow trailing whitespace 4f4fe6e libarchive 3.0.2-r4051 (reduced) 65b6e19 libarchive: Avoid bogus conversion warning from PGI compiler 9ccaeb1 libarchive: Suppress PathScale compiler warnings 2309438 libarchive: Rename isoent_rr_move_dir parameter isoent => curent b6ca96e libarchive: Include linux/types.h before linux/fiemap.h f293b73 libarchive: Define _XOPEN_SOURCE=500 on HP-UX 6781a09 libarchive: Cleanup after ZLIB_WINAPI check f15d757 libarchive: Remove hard-coded build configuration 3a9f449 libarchive: Use Apple copyfile.h API only if available 6af6b96 libarchive: Do not use MNT_NOATIME if not defined 02d5e40 libarchive: Check for 'struct statvfs' member 'f_iosize' 8b7ee30 libarchive: Do not use ST_NOATIME if not defined ...
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 6 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c43ca6a22a..c9ff2fc56d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -270,7 +270,7 @@ MACRO (CMAKE_BUILD_UTILITIES)
SET(CMAKE_ZLIB_INCLUDES ${ZLIB_INCLUDE_DIR})
SET(CMAKE_ZLIB_LIBRARIES ${ZLIB_LIBRARIES})
ELSE(CMAKE_USE_SYSTEM_ZLIB)
- SET(CMAKE_ZLIB_INCLUDES)
+ SET(CMAKE_ZLIB_INCLUDES ${CMake_SOURCE_DIR}/Utilities)
SET(CMAKE_ZLIB_LIBRARIES cmzlib)
ADD_SUBDIRECTORY(Utilities/cmzlib)
CMAKE_SET_TARGET_FOLDER(cmzlib "Utilities/3rdParty")
@@ -336,13 +336,14 @@ MACRO (CMAKE_BUILD_UTILITIES)
SET(CMAKE_TAR_INCLUDES ${LibArchive_INCLUDE_DIRS})
SET(CMAKE_TAR_LIBRARIES ${LibArchive_LIBRARIES})
ELSE(CMAKE_USE_SYSTEM_LIBARCHIVE)
- SET(HAVE_LIBZ 1)
- SET(HAVE_ZLIB_H 1)
SET(ZLIB_INCLUDE_DIR ${CMAKE_ZLIB_INCLUDES})
- SET(ZLIB_LIBRARIES ${CMAKE_ZLIB_LIBRARIES})
SET(ZLIB_LIBRARY ${CMAKE_ZLIB_LIBRARIES})
- SET(BUILD_ARCHIVE_WITHIN_CMAKE TRUE)
ADD_DEFINITIONS(-DLIBARCHIVE_STATIC)
+ SET(ENABLE_NETTLE OFF CACHE INTERNAL "Enable use of Nettle")
+ SET(ENABLE_OPENSSL ${CMAKE_USE_OPENSSL} CACHE INTERNAL "Enable use of OpenSSL")
+ SET(ENABLE_XATTR OFF CACHE INTERNAL "Enable extended attribute support")
+ SET(ENABLE_ACL OFF CACHE INTERNAL "Enable ACL support")
+ SET(ENABLE_ICONV OFF CACHE INTERNAL "Enable iconv support")
ADD_SUBDIRECTORY(Utilities/cmlibarchive)
CMAKE_SET_TARGET_FOLDER(cmlibarchive "Utilities/3rdParty")
SET(CMAKE_TAR_LIBRARIES cmlibarchive ${BZIP2_LIBRARIES})