summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2008-09-29 15:47:46 -0400
committerBill Hoffman <bill.hoffman@kitware.com>2008-09-29 15:47:46 -0400
commit6cf99d7bea3db24c27f08884239aae24bbd2b677 (patch)
tree2dda62019b67ca3774550da8af3d650d3bfab5b9 /CMakeLists.txt
parent5824aa614353b7a5443ab7fdfa95eddf062e04be (diff)
downloadcmake-6cf99d7bea3db24c27f08884239aae24bbd2b677.tar.gz
ENH: check in ability to build with new curl -f -DCMAKE_USE_NEW_CURL is set
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a54953de08..03a0e58d35 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -227,8 +227,8 @@ MACRO (CMAKE_BUILD_UTILITIES)
# Everything in the tree should be able to include files from the
# Utilities directory.
INCLUDE_DIRECTORIES(
- ${CMake_SOURCE_DIR}/Utilities
${CMake_BINARY_DIR}/Utilities
+ ${CMake_SOURCE_DIR}/Utilities
)
# check for the use of system libraries versus builtin ones
@@ -269,7 +269,13 @@ MACRO (CMAKE_BUILD_UTILITIES)
ADD_DEFINITIONS(-DCURL_STATICLIB)
SET(CMAKE_CURL_INCLUDES)
SET(CMAKE_CURL_LIBRARIES cmcurl)
- SUBDIRS(Utilities/cmcurl)
+ IF(CMAKE_USE_NEW_CURL)
+ # for cmake never build examples
+ SET(CURL_SKIP_EXAMPLES TRUE)
+ ADD_SUBDIRECTORY(Utilities/cmcurl-7.19.0)
+ ELSE(CMAKE_USE_NEW_CURL)
+ SUBDIRS(Utilities/cmcurl)
+ ENDIF(CMAKE_USE_NEW_CURL)
ENDIF(CMAKE_USE_SYSTEM_CURL)
#---------------------------------------------------------------------