summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Cedilnik <andy.cedilnik@kitware.com>2006-01-04 15:14:09 -0500
committerAndy Cedilnik <andy.cedilnik@kitware.com>2006-01-04 15:14:09 -0500
commit5358809a5c1010739923b3bec22a63ba4fe2f657 (patch)
tree44ad9fbf6e731063a13b9871ee7712c35446e8cc /CMakeLists.txt
parent0b40b42b0888857d770007bf7b7438f9291a67e5 (diff)
downloadcmake-5358809a5c1010739923b3bec22a63ba4fe2f657.tar.gz
ENH: More CPack stuff and fix zlib compression
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 16c8633ed0..14623037cc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -178,3 +178,14 @@ ADD_CUSTOM_TARGET(uninstall
# include support for making the release
INCLUDE (${CMake_SOURCE_DIR}/Utilities/Release/Release.cmake)
+
+# If the cmake version includes cpack, use it
+IF(${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION} GREATER 2.2)
+ SET(CPACK_PACKAGE_DESCRIPTION_SUMMARY "CMake is a build tool")
+ SET(CPACK_PACKAGE_VENDOR "Kitware")
+ SET(CPACK_PACKAGE_DESCRIPTION_FILE "${CMAKE_CURRENT_SOURCE_DIR}/Copyright.txt")
+ SET(CPACK_PACKAGE_VERSION_MAJOR "${CMake_VERSION_MAJOR}")
+ SET(CPACK_PACKAGE_VERSION_MINOR "${CMake_VERSION_MINOR}")
+ SET(CPACK_PACKAGE_VERSION_PATCH "${CMake_VERSION_PATCH}")
+ INCLUDE(CPack)
+ENDIF(${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION} GREATER 2.2)