summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Cedilnik <andy.cedilnik@kitware.com>2006-04-29 20:01:34 -0400
committerAndy Cedilnik <andy.cedilnik@kitware.com>2006-04-29 20:01:34 -0400
commitde4127cdda9dd7effc3d16fc8a1b0c1c9711308b (patch)
treee6b58b01a65dc8ffb92a8161d677ebdb29c5f43d /CMakeLists.txt
parent619ebce6cf2a0b03915387fb3c9bbd1cb39db795 (diff)
downloadcmake-de4127cdda9dd7effc3d16fc8a1b0c1c9711308b.tar.gz
ENH: Add more install registry options
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b29f1cf628..a3e3b8aed0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -262,6 +262,11 @@ IF(EXISTS "${CMAKE_ROOT}/Modules/CPack.cmake")
# sure there is at least one set of four (4) backlasshes.
SET(CPACK_PACKAGE_ICON "${CMake_SOURCE_DIR}/Utilities/Release\\\\CMakeInstall.bmp")
SET(CPACK_PACKAGE_EXECUTABLES "CMakeSetup" "CMake")
+ SET(CPACK_NSIS_INSTALLED_ICON_NAME "bin\\\\CMakeSetup.exe")
+ SET(CPACK_NSIS_DISPLAY_NAME "${CPACK_PACKAGE_INSTALL_DIRECTORY} a cross-platform, open-source build system")
+ SET(CPACK_NSIS_HELP_LINK "http:\\\\\\\\www.cmake.org")
+ SET(CPACK_NSIS_URL_INFO_ABOUT "http:\\\\\\\\www.kitware.com")
+ SET(CPACK_NSIS_CONTACT "cmake@cmake.org")
SET(CPACK_NSIS_MODIFY_PATH ON)
ELSE(WIN32 AND NOT UNIX)
SET(CPACK_PACKAGE_EXECUTABLES "ccmake" "CMake")