summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2019-05-07 13:11:36 -0400
committerBrad King <brad.king@kitware.com>2019-05-08 13:18:30 -0400
commit1069a3f02bbe12fdf326cf7cfdb12820cee6030a (patch)
tree4e91cbe745b04026838b4d52b10e0c16ffb7c379 /CMakeLists.txt
parent0af57a18520c0df50ba6609aa9cbd4af876b23f8 (diff)
downloadcmake-1069a3f02bbe12fdf326cf7cfdb12820cee6030a.tar.gz
Configure CMake itself with policies through CMake 3.14
In particular, set `CMP0082` to `NEW` to interleave install commands in the top-level directory with subdirectory installations.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fc033baed2..9274a8abd6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,7 +1,7 @@
# Distributed under the OSI-approved BSD 3-Clause License. See accompanying
# file Copyright.txt or https://cmake.org/licensing for details.
-cmake_minimum_required(VERSION 3.1...3.12 FATAL_ERROR)
+cmake_minimum_required(VERSION 3.1...3.14 FATAL_ERROR)
set(CMAKE_USER_MAKE_RULES_OVERRIDE_C ${CMAKE_CURRENT_SOURCE_DIR}/Source/Modules/OverrideC.cmake)
set(CMAKE_USER_MAKE_RULES_OVERRIDE_CXX ${CMAKE_CURRENT_SOURCE_DIR}/Source/Modules/OverrideCXX.cmake)
project(CMake)