summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2015-08-05 13:28:35 -0400
committerBrad King <brad.king@kitware.com>2015-08-05 13:29:57 -0400
commit26f5445bb461910efd42bc80a99a63dd53b49643 (patch)
treeac04413fd4bcb87e4550f4ba74afcfc9bf98691c /CMakeLists.txt
parenta15b69cbc75f475601f41c516330c679915676e4 (diff)
downloadcmake-26f5445bb461910efd42bc80a99a63dd53b49643.tar.gz
Do not install 3rd-party dependencies by default
Disable the CMake_INSTALL_DEPENDENCIES option by default and turn it on explicitly in our packaging scripts. This simplifies packaging in distributions that provide the dependencies for us without having to install them. We only need 3rd-party runtime dependencies to be installed for packaging with redistributable binaries.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a47c2ade7a..36244dd450 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -72,7 +72,7 @@ endmacro()
# option to disable installing 3rd-party dependencies
option(CMake_INSTALL_DEPENDENCIES
- "Whether to install 3rd-party runtime dependencies" ON)
+ "Whether to install 3rd-party runtime dependencies" OFF)
mark_as_advanced(CMake_INSTALL_DEPENDENCIES)
#-----------------------------------------------------------------------