summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKonstantin Podsvirov <konstantin@podsvirov.pro>2015-07-24 10:15:06 +0300
committerBrad King <brad.king@kitware.com>2015-07-27 10:30:41 -0400
commit068e7962bb8a90ae9ae6b7d6da520a70701820af (patch)
tree196b9da63a763e5a824ed67bbb2843249af0c556 /CMakeLists.txt
parent42f0155bb9f7cb65c7af103ec1170f4193244d69 (diff)
downloadcmake-068e7962bb8a90ae9ae6b7d6da520a70701820af.tar.gz
CMake: Add CMake_INSTALL_DEPENDENCIES option
By default this option is ON. Turn OFF to disable installing runtime 3rd-party dependencies.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5e94028478..a47c2ade7a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -70,6 +70,11 @@ macro(CMake_OPTIONAL_COMPONENT NAME)
endif()
endmacro()
+# option to disable installing 3rd-party dependencies
+option(CMake_INSTALL_DEPENDENCIES
+ "Whether to install 3rd-party runtime dependencies" ON)
+mark_as_advanced(CMake_INSTALL_DEPENDENCIES)
+
#-----------------------------------------------------------------------
# a macro to deal with system libraries, implemented as a macro
# simply to improve readability of the main script