summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2015-05-08 11:04:21 -0400
committerBrad King <brad.king@kitware.com>2015-05-08 11:04:21 -0400
commit3307e10fc4ef5ffb551df35bc0978a2543305e9d (patch)
treeaa50d969e63c5f6bc06b3481a79538ab3064dfed /CMakeLists.txt
parent6831f91a6c6d4f5d194c7a035c8de45f203f9cf8 (diff)
downloadcmake-3307e10fc4ef5ffb551df35bc0978a2543305e9d.tar.gz
Avoid using C++14 to build CMake if cstdio breaks
The GNU 4.8 standard library's cstdio header is not aware that C++14 honors C11's removal of "gets" from stdio.h and results in an error: /.../include/c++/4.8/cstdio:120:11: error: no member named 'gets' in the global namespace Detect this problematic case and default to using C++11 instead of C++14 for building CMake itself.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e979d4f38e..19d83f17e7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,7 +41,12 @@ if(NOT DEFINED CMAKE_C_STANDARD AND NOT CMake_NO_C_STANDARD)
set(CMAKE_C_STANDARD 11)
endif()
if(NOT DEFINED CMAKE_CXX_STANDARD AND NOT CMake_NO_CXX_STANDARD)
- set(CMAKE_CXX_STANDARD 14)
+ include(${CMake_SOURCE_DIR}/Source/Checks/cm_cxx14_cstdio.cmake)
+ if(NOT CMake_CXX14_CSTDIO_BROKEN)
+ set(CMAKE_CXX_STANDARD 14)
+ else()
+ set(CMAKE_CXX_STANDARD 11)
+ endif()
endif()
# option to set the internal encoding of CMake to UTF-8