summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-03-03 12:39:30 -0500
committerBrad King <brad.king@kitware.com>2014-03-03 15:26:48 -0500
commit3c01ee5adceafb0febd9cedab9211f830f953c03 (patch)
treee562cc2f1cd8991c7655e9f429718c6a71f94873 /CMakeLists.txt
parentdaf0a5fedebb2dac66ac26516eeeff502ddcf432 (diff)
downloadcmake-3c01ee5adceafb0febd9cedab9211f830f953c03.tar.gz
Tests: Drop CMAKE_TEST_MSVC and test MSVC directly
Now that we no longer support running tests using a different generator we can trust the MSVC platform indicator directly.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 0 insertions, 11 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4c2c20b735..b9f96e271b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -117,17 +117,6 @@ macro(CMAKE_SETUP_TESTING)
set(CMAKE_TEST_GENERATOR "${CMAKE_GENERATOR}")
set(CMAKE_TEST_GENERATOR_TOOLSET "${CMAKE_GENERATOR_TOOLSET}")
- # Are we testing with the MSVC compiler?
- set(CMAKE_TEST_MSVC 0)
- if(MSVC AND NOT CMAKE_TEST_DIFFERENT_GENERATOR)
- set(CMAKE_TEST_MSVC 1)
- else()
- if("${CMAKE_TEST_GENERATOR}" MATCHES "NMake" OR
- "${CMAKE_TEST_GENERATOR}" MATCHES "Visual Studio")
- set(CMAKE_TEST_MSVC 1)
- endif()
- endif()
-
set(CMAKE_TEST_SYSTEM_LIBRARIES 0)
foreach(util CURL EXPAT XMLRPC ZLIB)
if(CMAKE_USE_SYSTEM_${util})