summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-10-21 15:08:07 -0400
committerCMake Topic Stage <kwrobot@kitware.com>2014-10-21 15:08:07 -0400
commit95d84f76d9a8e27eb974fce7d06b7f2e312a05e6 (patch)
tree727105aeb6ebba64c18a3af64c207e50cf900104 /CMakeLists.txt
parentc8ba39719409dc106f76c0b67f805158be01b3b4 (diff)
parent29c3edb87adedd82e816552d958f4c3540a1511b (diff)
downloadcmake-95d84f76d9a8e27eb974fce7d06b7f2e312a05e6.tar.gz
Merge topic 'cmake-cmp0054-warnings'
29c3edb8 Avoid if() quoted auto-dereference
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dfef067424..c2060eabf3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -555,7 +555,7 @@ CMAKE_SETUP_TESTING()
if(NOT CMake_TEST_EXTERNAL_CMAKE)
if(NOT CMake_VERSION_IS_RELEASE)
- if("${CMAKE_C_COMPILER_ID}" STREQUAL "GNU" AND
+ if(CMAKE_C_COMPILER_ID STREQUAL "GNU" AND
NOT "${CMAKE_C_COMPILER_VERSION}" VERSION_LESS 4.2)
set(C_FLAGS_LIST -Wcast-align -Werror-implicit-function-declaration -Wchar-subscripts
-Wall -W -Wpointer-arith -Wwrite-strings -Wformat-security