summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-12-01 08:57:16 -0500
committerCMake Topic Stage <kwrobot@kitware.com>2014-12-01 08:57:16 -0500
commit4d9fec4fb327b886c66a12a657864cb3fac69250 (patch)
tree423fe73b7b5883fa4aeadd588eda98a6dea6160e /CMakeLists.txt
parentb9d437a2921cd808cff27ccdd4d39cabcd87bf5a (diff)
parentd49f1c5e9400c6b5d6dc205b4dadad2fa21f6eb0 (diff)
downloadcmake-4d9fec4fb327b886c66a12a657864cb3fac69250.tar.gz
Merge topic 'use-latest-language-dialects'
d49f1c5e Build CMake with most-recent available language dialect.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ba7f129fbe..ad3bb97344 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -36,6 +36,10 @@ if("${CMake_SOURCE_DIR}" STREQUAL "${CMAKE_SOURCE_DIR}")
endmacro()
endif()
+# Use most-recent available language dialects with GNU and Clang
+set(CMAKE_C_STANDARD 11)
+set(CMAKE_CXX_STANDARD 14)
+
# option to set the internal encoding of CMake to UTF-8
option(CMAKE_ENCODING_UTF8 "Use UTF-8 encoding internally (experimental)." OFF)
mark_as_advanced(CMAKE_ENCODING_UTF8)