summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-10-30 09:11:10 -0400
committerBrad King <brad.king@kitware.com>2014-11-10 10:13:37 -0500
commit19593042959274fab45f6bc0ef77d6ddc4532a0f (patch)
tree48d2ac9e1b1bc32729981f2dd72f9825c6c8cfd3 /CMakeLists.txt
parentcf54aebb968aa66b0990174db8b73c405f6e9c98 (diff)
downloadcmake-19593042959274fab45f6bc0ef77d6ddc4532a0f.tar.gz
curl: Configure build to work within CMake
Set curl build options as needed for CMake rather than presenting them to the user in the cache. Drop the CMAKE_BUILD_CURL_SHARED option for now. Change the curl library name to 'cmcurl'. Disable blocks of code within curl CMakeLists.txt files that we do not need for CMake, but leave the code in place to make merging with curl updates easier.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 1 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c2060eabf3..58e0a1f220 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -271,10 +271,7 @@ macro (CMAKE_BUILD_UTILITIES)
set(CURL_SPECIAL_ZLIB_H ${CMAKE_ZLIB_HEADER})
set(CURL_SPECIAL_LIBZ_INCLUDES ${CMAKE_ZLIB_INCLUDES})
set(CURL_SPECIAL_LIBZ ${CMAKE_ZLIB_LIBRARIES})
- option(CMAKE_BUILD_CURL_SHARED "Should curl be built shared" FALSE)
- if(NOT CMAKE_BUILD_CURL_SHARED)
- add_definitions(-DCURL_STATICLIB)
- endif()
+ add_definitions(-DCURL_STATICLIB)
set(CMAKE_CURL_INCLUDES)
set(CMAKE_CURL_LIBRARIES cmcurl)
if(CMAKE_TESTS_CDASH_SERVER)